• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 2.0 Adding new page to Navigation?

RobParker

Well-known member
#1
What's the correct procedure for creating a new page and adding it to it's own navigation tab?

At the minute it seems a little confusing.

If I create the Node first it asks for the Navigation Section but that doesn't exist yet.

If instead I got to create the Navigation tab first it asks for the node which doesn't exist yet.
 

Chris D

XenForo developer
Staff member
#2
If you want a node to have its own navigation tab, then you create the node first, then you create the node type navigation entry.

If you want a node to activate an existing navigation entry (e.g. if for some reason you wanted a forum to activate the Members tab) then you set that on the node directly.
 

RobParker

Well-known member
#3
When creating a page you have these options

Screen Shot 2017-09-09 at 00.01.38.png

Say I want this page to have it's own navigation section what do I do? Create the forum but leave it as default. Then go create the navigation and then come back and change the nav section to the newly created one?
 

Kirby

Well-known member
#6
Yes, but choose the "node" type. That takes care of everything else.
Hmm, this does not seem to work for me (on Beta 1).
I still have to got back to Edit Forum and set the Navigation Section after creating the navigation if I want the tab to be activated when accessing content within the subtree of the node.
 

Chris D

XenForo developer
Staff member
#7
You know, you might be right... I thought the default selection was inferred by the fact that it was a node type. Either I'm wrong, or there's a regression there. I actually think I might be wrong, though we'll look into it.

So, indeed @Kirby was correct :)