1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Add-on Installation - php page comes back but nothing happens

Discussion in 'Installation, Upgrade, and Import Support' started by serverguy, Aug 15, 2016.

  1. serverguy

    serverguy New Member

    Hello,

    The admin.php?add-ons/install-upgrade page has stopped working for me. I am used to installing add-ons by unzipping the zip file contents on my server and then copying the files from the zip to the right server root locations on the server. Then I give the admin form the xml file to use. (Option 3). This has stopped working. Now when I provide the xml file and click 'Install or Upgrade' the page returns immediately and nothing apparently happens. I don't see any output in the php-fpm error log. I could use some help debugging this one.

    Thanks,

    J
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    This is likely an issue with the add-on itself. I recommend posting about that in the discussion thread for that resource.
     
  3. serverguy

    serverguy New Member

    I thought so too so I tried a different add-on and the same thing occurs.
     
  4. serverguy

    serverguy New Member

    Without digging into the XenForo_Dependencies_Admin class, can you tell me more about how the add-on installation works? What directories on the server does it check for code? Where does it expect to find the xml file that you upload?

    Better yet, is there a way to install add-ons from the command line?

    J
     
  5. Chris D

    Chris D XenForo Developer Staff Member

    I mean it's likely related to the install and upgrade add on you mentioned.

    That's not default XF functionality.
     
  6. serverguy

    serverguy New Member

    My apologies. It's been a long time since I initially installed. What's the default XF functionality to adding Add-ons?
     
  7. Chris D

    Chris D XenForo Developer Staff Member

    Well actually it's the same as the "Option 3" thing you mentioned - just uploading the files manually and browsing for the XML file.

    If that's all you do, you'd might as well just disable the add on installer add on.
     
  8. serverguy

    serverguy New Member

    I see it now in the add-ons... I disabled it and tried the XF default method of installing add-ons and it looks to be working. Thanks!
     
  9. serverguy

    serverguy New Member

    Sorry for the 'dumb user' post. That worked.
     

Share This Page