XF 2.2 Add-on Error After Upgrade -- Disable Add-on?

Static-Xbox

Active member
Edit -- my apologies, disabled add-on listeners, got in, disabled add-on, all's well!

...so I did a dumb. Normally when I upgrade I disable add-ons first, upgrade, install add-on upgrades as needed, and then re-activate...I just upgraded from 2.1 -> 2.2 without doing that, and now I'm getting this error because of ThemeHouse's React Plus add-on...

Code:
An exception occurred: [ErrorException] [E_WARNING] Declaration of ThemeHouse\ReactPlus\XF\Template\Templater::fnReactions($templater, &$escape, XF\Mvc\Entity\Entity $content, $link, array $linkParams = Array) should be compatible with XF\Template\Templater::fnReactions($templater, &$escape, $content, $link, array $linkParams = Array) in src/addons/ThemeHouse/ReactPlus/XF/Template/Templater.php on line 72

[LIST=1]
[*]   
[*]XF::handlePhpError() in src/vendor/composer/ClassLoader.php at line 444
[*]  
[*]include() in src/vendor/composer/ClassLoader.php at line 444
[*]  
[*]Composer\Autoload\includeFile() in src/vendor/composer/ClassLoader.php at line 322
[*]  
[*]Composer\Autoload\ClassLoader->loadClass()
[*]  
[*]spl_autoload_call()
[*]  
[*]class_exists() in src/XF/Extension.php at line 172
[*]  
[*]XF\Extension->extendClass() in src/XF/App.php at line 2837
[*]  
[*]XF\App->extendClass() in src/XF/App.php at line 1801
[*]  
[*]XF\App->setupTemplaterObject() in src/XF/App.php at line 1371
[*]  
[*]XF\App->XF\{closure}() in src/XF/Container.php at line 28
[*]  
[*]XF\Container->offsetGet() in src/XF/App.php at line 3201
[*]  
[*]XF\App->templater() in src/XF/Admin/App.php at line 97
[*]  
[*]XF\Admin\App->preRender() in src/XF/Mvc/Dispatcher.php at line 395
[*]  
[*]XF\Mvc\Dispatcher->render() in src/XF/Mvc/Dispatcher.php at line 58
[*]  
[*]XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2326
[*]  
[*]XF\App->run() in src/XF.php at line 488
[*]  
[*]XF::runApp() in admin.php at line 13
[/LIST]
I can't get into ACP to disable the add-on, and the forum is now completely inaccessible. What's the best approach to get it deactivated so I can get back into my board?
 
Last edited:
Top