1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Add "iframe" into a topic

Discussion in 'XenForo Questions and Support' started by Betclever, Feb 24, 2015.

  1. Betclever

    Betclever Active Member

    Hello,

    Is it possible to add an "iframe" into a topic.
    In fact, I want to add this widget into a topic :

    Is this possible?
    Shall I activate html code?

    If yes...

    How please?
     
  2. Mike

    Mike XenForo Developer Staff Member

    The only way to get something like that into a post would be with a custom BB code.
     
  3. Betclever

    Betclever Active Member

  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. Betclever

    Betclever Active Member

    @Brogan

    Not to miss respect to you but what can I do with this tuto?

    I'm not a dev. If I ask help, it's to avoid this!
    This tuto is chinese for newbie like me.

    pffffff
     
  6. Betclever

    Betclever Active Member

    @Mike

    I have checked the link above but it is chinese for me.
    What must I write in these cases?

    I only have a Iframe code...
    I understand what I can add as title and description but for html replacement and the other options are chinese for a newbie like me...

    How can I put this Iframe code with the functionn BBcode?

    Thanks.
     
  7. Mike

    Mike XenForo Developer Staff Member

    Create the BB code with whatever tag name (let's call it "espn") and title you want. Enter the HTML you want to see in the HTML replacement box. Enable the "Display HTML replacement when empty" option.

    Then in the post enter:
    Code:
    [espn][/espn]
    Your iframe should appear.
     
  8. Betclever

    Betclever Active Member

    @Mike , all

    Hello,

    This is what I did but I see on topic my own forum page. ^^
    I did something wrong.

    Please find an ex in att.

    What's wrong?
     

    Attached Files:

  9. Mike

    Mike XenForo Developer Staff Member

    With that regex, you probably want:
    #^https?://#i

    However, that may not be the issue. Can you provide a link where the BB code was used and show what you typed in the post?
     
  10. Betclever

    Betclever Active Member

  11. Mike

    Mike XenForo Developer Staff Member

    It won't show anything to users that they can't see -- you're seeing things because it's loading the page in your admin context; if another user loads the iframe, they'll see it in their context.

    Unfortunately, I do really need to see it in place to confirm what's going on.
     
  12. Betclever

    Betclever Active Member

    @Mike

    I understand. Can you ping me when you are available so I add the code when you will be available?

    Thanks Mike
     

Share This Page