1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 access denied mysql

Discussion in 'Troubleshooting and Problems' started by oloman, Feb 25, 2015.

  1. oloman

    oloman Active Member


    I changed my server, but I get this Mysql message every time:

    I played with a lot of passwords etc, but there is nothing to do. I am sure, because my login/password works with a wordpress installed on the same server.

    Thank you for your help.

    An exception occurred: Access denied for user '‘root’'@'localhost' (using password: YES) in /home/femiboardxen/library/Zend/Db/Adapter/Mysqli.php on line 333

    1. Zend_Db_Adapter_Mysqli->_connect() in Zend/Db/Adapter/Abstract.php at line 315
    2. Zend_Db_Adapter_Abstract->getConnection() in XenForo/Application.php at line 684
    3. XenForo_Application->loadDb()
    4. call_user_func_array() in XenForo/Application.php at line 921
    5. XenForo_Application->lazyLoad() in XenForo/Application.php at line 952
    6. XenForo_Application::get() in XenForo/Application.php at line 1336
    7. XenForo_Application::getDb() in XenForo/Error.php at line 52
    8. XenForo_Error::unexpectedException() in XenForo/Application.php at line 363
    9. XenForo_Application::handleException()
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Confirm the details in the library/config.php file match those of the database instance on the new server.
  3. Tracy Perry

    Tracy Perry Well-Known Member

    And set up another account to use instead of root. You should NEVER be using the root account to run your site DB connection with.

Share This Page