1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[AA] Multi Prefix [Paid] 1.5.0

Threads can only have one prefix? Says who? Let them have multiples!

  1. Daniel Hood

    Daniel Hood Well-Known Member

    Daniel Hood submitted a new resource:

    [XenMods] Multi Prefix - Threads can only have one prefix? Says who? Let them have multiples!

    Read more about this resource...
    DRE, Lisa, cclaerhout and 1 other person like this.
  2. Lisa

    Lisa Well-Known Member

    Soooo pleased you managed to make this, @Daniel Hood . *makes a list of other mods that really need doing* :D

    *edited to add* - Installed, works perfectly!

    Last edited: Sep 26, 2013
    Daniel Hood likes this.
  3. DRE

    DRE Well-Known Member

    Wow you pulled it off. Good job sir!
    Lisa likes this.
  4. TsinJu

    TsinJu Well-Known Member

    is it possible to choose in what forums this can be enabled? or is it global enabled?
  5. Daniel Hood

    Daniel Hood Well-Known Member

  6. Lisa

    Lisa Well-Known Member

    Hey, @Daniel Hood - doesn't play well with AnonymousPosting :) Get the following error when trying to post with both addons active. If I switch off multiprefix, posting works fine.

    ErrorException: Argument 2 passed to AnonymousPosting_ControllerPublic_Forum: processAnonymousPosting() must be an instance of XenForo_DataWriter_DiscussionMessage_Post, null given, called in /library/AnonymousPosting/DataWriter/Discussion/Thread.php on line 11 and defined - library/AnonymousPosting/ControllerPublic/Forum.php:16
  7. Daniel Hood

    Daniel Hood Well-Known Member

    Interesting... looking now.
    Lisa likes this.
  8. Daniel Hood

    Daniel Hood Well-Known Member

    Lisa likes this.
  9. Lisa

    Lisa Well-Known Member

    Works perfectly with it now (y)
    Daniel Hood likes this.
  10. oman

    oman Well-Known Member

    Just wanted to say this is a brilliant, yet simple add on. I'm very happy with how it works @Daniel Hood ! Keep up the good work!
    Daniel Hood likes this.
  11. DivineSky

    DivineSky New Member

    Is it possible to Setup Different prefixes to be used as First and Second? as in example have
    1st Prefix List: - PC, - Xbox, - PSN, - Nintendo
    2nd Prefix List - Shooter, Stategy, Fighters, Racing, Multi, etc.

    Furthermore allowing us to Force the 1st Prefix to be used, But leaving the second Optional would be useful too.
    Renegade, ToxicShade, bobs409 and 2 others like this.
  12. indicator

    indicator Member

    Hi there, i just bought the license. i didn't turned out what i expected. my website is more of user input based website. user won't know if they can select two prefix.
    i wanted to ask that is it possible to have two selection option for prefix next to title to choose two prefix instead of selecting two from one prefix selection.
    Thanks for assistance
    @Daniel Hood
  13. Daniel Hood

    Daniel Hood Well-Known Member

    I'm not entirely sure what you mean. If the add on isn't working for you I don't mind refunding but I'm not clear what you're suggesting.
  14. oman

    oman Well-Known Member

    So @indicator ,
    Do you mean having two of the '(No Prefix)' things when creating a thread rather than just the single '(No Prefix)'?

    I guess it could work both ways, but I quite like it how it is.
    Daniel Hood likes this.
  15. Daniel Hood

    Daniel Hood Well-Known Member

    We thought of that when developing it but what if you end up with someone using 5 prefixes, the thread title box wouldn't look good.
    oman likes this.
  16. TBDragon

    TBDragon Active Member

    i put my problem in ur forum here
    hope u can solve it
    right now i just disable it so i can add threads
  17. indicator

    indicator Member

    one more thing which I want to point out that, i applied one prefix and posted the thread. after that if I want to add one more prefix to the same post by editing, it wouldn't let me select select two prefix. is it possible to select two prefix after thread post?
  18. Daniel Hood

    Daniel Hood Well-Known Member

    Yes, you should have just had to click the drop down and checked the additional prefixes.
  19. arms

    arms Active Member

    @Daniel Hood

    Just trying this out and it seems that its incompatible with:


    Server Error
    Mysqli prepare error: Incorrect parameter count in the call to native function 'FIND_IN_SET'
    Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
    Zend_Db_Adapter_Abstract->fetchOne() in XenForo/Model/Thread.php at line 574
    XenForo_Model_Thread->countThreads() in XenForo/Model/Thread.php at line 637
    XenForo_Model_Thread->countThreadsInForum() in XenForo/ControllerPublic/Forum.php at line 119
    XenForo_ControllerPublic_Forum->actionForum() in Waindigo/CustomFields/Extend/XenForo/ControllerPublic/Forum.php at line 29
    Waindigo_CustomFields_Extend_XenForo_ControllerPublic_Forum->actionForum() in Waindigo/ThreadFilters/Extend/XenForo/ControllerPublic/Forum.php at line 16
    Waindigo_ThreadFilters_Extend_XenForo_ControllerPublic_Forum->actionForum() in XenForo/FrontController.php at line 347
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /var/sites/p/ch.com/public_html/index.php at line 13
  20. Daniel Hood

    Daniel Hood Well-Known Member

    Very odd. I'll have to download that add on later and see what the deal is.
    arms likes this.

Share This Page