• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

[8wayRun.Com] XenPorta (Portal)

Status
Not open for further replies.

CFodder

Well-known member
#21
Sorry for the multiple posts but the error is back, but I've figured out what it is. It's whenever I enable the Wikinav, even if I have 0 or another value for the quicklinks. Here's the server log error:

Server Error Log

Error Info
XenForo_Exception: Invalid model 'EWRcarta_Model_Lists' specified - library/XenForo/Model.php:192
Generated By: CFodder, A moment ago

Stack Trace
#0 /home/ ... /xf/library/XenForo/Model.php(113): XenForo_Model::create('EWRcarta_Model_...')
#1 /home/ ... /xf/library/EWRporta/Modules/Wikinav.php(7): XenForo_Model->getModelFromCache('EWRcarta_Model_...')
#2 /home/ ... /public_html/xf/library/EWRporta/ViewPublic/Portal.php(19): EWRporta_Modules_Wikinav->getModule(Array)
#3 /home/ ... /xf/library/XenForo/ViewRenderer/Abstract.php(212): EWRporta_ViewPublic_Portal->renderHtml()
#4 /home/ ... /xf/library/XenForo/ViewRenderer/HtmlPublic.php(69): XenForo_ViewRenderer_Abstract->renderViewObject('EWRporta_ViewPu...', 'Html', Array, 'EWRporta_Portal')
#5 /home/ ... /xf/library/XenForo/FrontController.php(520): XenForo_ViewRenderer_HtmlPublic->renderView('EWRporta_ViewPu...', Array, 'EWRporta_Portal', NULL)
#6 /home/ ... /xf/library/XenForo/FrontController.php(156): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_HtmlPublic), Array)
#7 /home/ ... /xf/index.php(15): XenForo_FrontController->run()
#8 {main}
Request State
array(3) {
["url"] => string(35) "http://xf.onlinedawdlers.com/portal"
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}
}
 

Jaxel

Well-known member
#22
XenForo_Exception: Invalid model 'EWRcarta_Model_Lists'

You need to have XenCarta installed to use that module.
 

Jaxel

Well-known member
#23
To show how easy it is to create modules for this mod... I have just created this "Recent Status Updates" module. This module will display the most recent status messages posted by your users...
  • Will only display status updates, not profile posts or comments
  • Will only display ONE status update per user, if a user has made the last 5 entries in the system, it will only take the most recent update, and then ignore the rest.
Just upload StatusUpdates.php to /library/EWRporta/Modules/ and then import the module XML... thats it!

Untitled-1.jpg
 

Attachments

Booth

Well-known member
#25
This is much better.

The only problems I can see are that there is no sub menu (which I know is more an issue with XF itself at the moment).

And also the meta is missing from the source on the portal page. Not good for search engines.
 

Jaxel

Well-known member
#26

Paul

Well-known member
#29
Jaxel,

Just installed - many thanks.

Have changed permissions for Admins to access in ACP, however whenever i go to /portal/modules as a logged in admin i get...

Error


You do not have permission to view this page or perform this action.

Am i missing something here?? :)

If you go to /portal though it does display the news tho....

Thanks
Paul

EDIT - Well not sure exactly what i did in the Admin CP, went in unchecked and re-checked the options, saved again, and i can seem to get in now - maybe one to watch!!!
 

Dakis

Well-known member
#31
Nice work, I think we might be using this.

Is there any easy way to display an attachment from the first post instead of the member's avatar? :)
 

Weiyan

Well-known member
#32
Installed on a test site. The content extract doesn't appear.
Could I add the the TaigaChat Ajax-Shoutbox above the forum list?

Thank you.
 

Attachments

Dakis

Well-known member
#33
Thanks Jaxel, I've installed as test for now, this is great work :)

One question that has been placed already in the old portal thread, don't the blocks/modules take into account usergroups permissions for their content? For example in my latest threads block I can see as guest threads that I don't have access to (from private forums for example). Am I missing something or is this going to be fixed in later stage? :)
 

Marc

Well-known member
#34
Looking good. Think I will be implementing this on my forum .... Er .. when I decide what Im using xenforo for LOL ..
 

Jaxel

Well-known member
#35
Thanks Jaxel, I've installed as test for now, this is great work :)

One question that has been placed already in the old portal thread, don't the blocks/modules take into account usergroups permissions for their content? For example in my latest threads block I can see as guest threads that I don't have access to (from private forums for example). Am I missing something or is this going to be fixed in later stage? :)
I dont have private forums on my test site... but I think I ahve this fixed... please test and tell me your results:

in "EWRporta_Model_Threads" find:
Code:
			'postCountUserId' => $visitor['user_id'],
add below:
Code:
			'permissionCombinationId' => $visitor['user_id'],
 

ArnyVee

Well-known member
#36
In addition to our question about about the permissions, I have a couple of additional questions....

Can you make an option to allow more than one forum to select your 'news' from?
Can we have attachments display as a featured image in the post?
And finally, can we move the latest threads to the sidebar rather than having it above the 'news' articles/posts?
 

ArnyVee

Well-known member
#37
I dont have private forums on my test site... but I think I ahve this fixed... please test and tell me your results:

in "EWRporta_Model_Threads" find:
Code:
			'postCountUserId' => $visitor['user_id'],
add below:
Code:
			'permissionCombinationId' => $visitor['user_id'],
Added that to the site and it still displays private forum posts in the latest threads at the top. Any other suggestions?
 

ddmmh

Well-known member
#38
Hi,
This might be a dumb question.... I have a custom XenForo theme. I really would love to use the portal its perfect for what I need but will this work with a custom template or does it have to be the default ? Cheers.
 

Jeremy

Well-known member
#39
It will / should work... The only thing is if it has template edits (I don't think so...), you'll have to adapt them.
 
Status
Not open for further replies.