• This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

[8wayRun.Com] XenMedio (Media)

Status
Not open for further replies.

shenmuee

Active member
it be awesome to have a "Latest Media" or "Most Popular Media" for the sidebar on the forum...
by the way, would be great to add my playlist videos on my own profile...
 

Lenin

Active member
Installation instructions:

go to your admin panel, Home/ languages / import a language / select the file:EWRmedio-language-Espanol.xml from your computer / overwrite language, choose and language-Spanish or Spanish-(EN)-Tu-BETA_6.xml or using import and ready...


About the translation:
version: [8wayRun.com] XenMedio (Media) 1.2.1
compatible with XenForo Beta 6


Instalación de la traducción:

se van a su panel de administración, Inicio/idiomas/importar un idioma/seleccionan el archivo: EWRmedio-language-Espanol.xml desde su ordenador/sobreescribir idioma y eligen español o Idioma-Español-(ES)-Tu-BETA_6.xml o el que usen importar y listo..


Sobre la traducción:
versión: [8wayRun.Com] XenMedio (Media) 1.2.1
compatible con XenForo beta 6

XenFacil.com tu comunidad XenForo en español :D
 

Attachments

Jaxel

Well-known member
[8wayRun.Com] XenMedio (Media) v1.2.2 CHANGELOG
  • [medio] bbcode now has an "=full" option for full media details within an embed.
  • auto generated threads now use the built in [medio=full] bbcode.
  • fixed a bug in thread commenting where comments linked to a dead url.
  • the [medio] popout now properly checks for permissions when playing media.
  • support has been added for "gallery" based service hosters such as flickr.
  • submissions now properly check for uniqueness with additional service value 2.
  • category listing has been optimized to significantly reduce the number of queries.
 

glorify

Well-known member
Hey Jaxel, just a question. If I added this to a board I am doing, importing a bunch of videos, etc THEN imported my community, would the videos stay intact?

I know, stupid question..

Thanks in advance.
 

Jaxel

Well-known member
Hey Jaxel, just a question. If I added this to a board I am doing, importing a bunch of videos, etc THEN imported my community, would the videos stay intact?

I know, stupid question..

Thanks in advance.
No idea. depends on the import script... does it wipe your existing database, or does it simply add onto it? If it adds onto it, then the videos should stay intact.
 

glorify

Well-known member
Don't know. Awaiting an ipb import script. I would guess in theory, it wouldn't wip the whole db, but import my current db, then I would be able to merge admins. If the admin posted the vids, I guess they would stay. (I hope).

I just would rather get this ready now than after the import.
 

iTuN3r

Well-known member
[8wayRun.Com] XenMedio (Media) v1.2.2 CHANGELOG
  • [medio] bbcode now has an "=full" option for full media details within an embed.
  • auto generated threads now use the built in [medio=full] bbcode.
  • fixed a bug in thread commenting where comments linked to a dead url.
  • the [medio] popout now properly checks for permissions when playing media.
  • support has been added for "gallery" based service hosters such as flickr.
  • submissions now properly check for uniqueness with additional service value 2.
  • category listing has been optimized to significantly reduce the number of queries.

Great but i have one question is it Possible to Disable Users from Submitting videos in Main Category and use Sub categories to Submit Videos ... Cause i know few boards out there will sure have various Main Categories and Sub Categories in that case i would like users to use sub categories to submit medias instead of Main Categories.
 

Jaxel

Well-known member
Great but i have one question is it Possible to Disable Users from Submitting videos in Main Category and use Sub categories to Submit Videos ... Cause i know few boards out there will sure have various Main Categories and Sub Categories in that case i would like users to use sub categories to submit medias instead of Main Categories.
Will add to next version.
 

Anthony Parsons

Well-known member
[8wayRun.Com] XenMedio (Media) v1.2.2 CHANGELOG
  • [medio] bbcode now has an "=full" option for full media details within an embed.
  • auto generated threads now use the built in [medio=full] bbcode.
  • fixed a bug in thread commenting where comments linked to a dead url.
  • the [medio] popout now properly checks for permissions when playing media.
  • support has been added for "gallery" based service hosters such as flickr.
  • submissions now properly check for uniqueness with additional service value 2.
  • category listing has been optimized to significantly reduce the number of queries.
Just tried to install this upgrade, overwrote existing files, then upgrade, got the following error on a development beta 6 install which is default with only your products added to it.

Server Error

Mysqli statement execute error : Specified key was too long; max key length is 1000 bytes

  1. [*]Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    [*]Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    [*]Zend_Db_Adapter_Abstract->query() in EWRmedio/Install.php at line 93
    [*]EWRmedio_Install::installCode()
    [*]call_user_func() in XenForo/Model/AddOn.php at line 214
    [*]XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
    [*]XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 226
    [*]XenForo_ControllerAdmin_AddOn->actionUpgrade() in XenForo/FrontController.php at line 310
    [*]XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    [*]XenForo_FrontController->run() in /******/forum/admin.php at line 13
 

Veer

Well-known member
Got this when upgrade on XF Beta 6

Server Error

Mysqli statement execute error : Unknown column 'service_type' in 'EWRmedio_media'

Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
Zend_Db_Adapter_Abstract->query() in EWRmedio/Install.php at line 227
EWRmedio_Install::addColumnIfNotExist() in EWRmedio/Install.php at line 157
EWRmedio_Install::installCode()
call_user_func() in XenForo/Model/AddOn.php at line 214
XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 226
XenForo_ControllerAdmin_AddOn->actionUpgrade() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /***/***/***/public_html/admin.php at line 13
 

Anthony Parsons

Well-known member
Nope... still getting the same error when trying to upgrade from 1.2.1

Server Error

Mysqli statement execute error : Specified key was too long; max key length is 1000 bytes
  1. [*]Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    [*]Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    [*]Zend_Db_Adapter_Abstract->query() in EWRmedio/Install.php at line 93
    [*]EWRmedio_Install::installCode()
    [*]call_user_func() in XenForo/Model/AddOn.php at line 214
    [*]XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
    [*]XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 226
    [*]XenForo_ControllerAdmin_AddOn->actionUpgrade() in XenForo/FrontController.php at line 310
    [*]XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
 

Jaxel

Well-known member
Nope... still getting the same error when trying to upgrade from 1.2.1

Server Error

Mysqli statement execute error : Specified key was too long; max key length is 1000 bytes
  1. [*]Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    [*]Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    [*]Zend_Db_Adapter_Abstract->query() in EWRmedio/Install.php at line 93
    [*]EWRmedio_Install::installCode()
    [*]call_user_func() in XenForo/Model/AddOn.php at line 214
    [*]XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
    [*]XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 226
    [*]XenForo_ControllerAdmin_AddOn->actionUpgrade() in XenForo/FrontController.php at line 310
    [*]XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
What version of MySQL do you have? It appears to be an old MySQL bug:
http://bugs.mysql.com/bug.php?id=6604

For now, what you can do is find line 88 on Install.php
Code:
UNIQUE KEY `UNIQUE` (`service_id`,`service_value`,`service_value2`),
and replace it with:
Code:
UNIQUE KEY `UNIQUE` (`service_id`,`service_value`(100),`service_value2`(100)),
 

Cory Booth

Well-known member
Code:
Mysqli statement execute error : Unknown column 'service_type' in 'EWRmedio_media'

   1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 317
   2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
   3. Zend_Db_Adapter_Abstract->query() in EWRmedio/Install.php at line 227
   4. EWRmedio_Install::addColumnIfNotExist() in EWRmedio/Install.php at line 157
   5. EWRmedio_Install::installCode()
   6. call_user_func() in XenForo/Model/AddOn.php at line 214
   7. XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
   8. XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 226
   9. XenForo_ControllerAdmin_AddOn->actionUpgrade() in XenForo/FrontController.php at line 310
  10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  11. XenForo_FrontController->run() in /home4/thebooth/public_html/aquia/admin.php at line 13
Going to add it manually
 

Jaxel

Well-known member
Code:
Mysqli statement execute error : Unknown column 'service_type' in 'EWRmedio_media'

   1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 317
   2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
   3. Zend_Db_Adapter_Abstract->query() in EWRmedio/Install.php at line 227
   4. EWRmedio_Install::addColumnIfNotExist() in EWRmedio/Install.php at line 157
   5. EWRmedio_Install::installCode()
   6. call_user_func() in XenForo/Model/AddOn.php at line 214
   7. XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
   8. XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 226
   9. XenForo_ControllerAdmin_AddOn->actionUpgrade() in XenForo/FrontController.php at line 310
  10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  11. XenForo_FrontController->run() in /home4/thebooth/public_html/aquia/admin.php at line 13
Going to add it manually
DO NOT ADD IT MANUALLY.

Please download the new version... thats a typo... its supposed to be EWRmedio_services not EWRmedio_media
 
Status
Not open for further replies.
Top