• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 • character from vB displayed literally

Stuart Wright

Well-known member
#1
So in our vB forums the • character, copied from Word and pasted in to a thread, is displayed as a bullet point dot.
In XF, it's displayed as •

I'm assuming that all odd characters like this will be displayed in the same way.
Is there anything I can do about this to fix it?
Thanks.
 

Brogan

XenForo moderator
Staff member
#2
Sounds like you may need an add-on to convert the HTML symbol entities.

Why are they being used in posts anyway?
 

Brogan

XenForo moderator
Staff member
#4
When I paste from Word here I get this:

· This is a bullet point pasted from Word

So it sort of works, it's better than the HTML entity code but not as defined as a bullet which looks like this:
  • This is a manually inserted bullet
 

Mike

XenForo developer
Staff member
#5
I should note that this is handled in the standard importer.

You'll probably need to write some queries to replace these entities with standard UTF-8 characters after the fact. (Individual characters can be replaced directly in MySQL but doing it generally would likely require custom PHP to do the conversions.)
 

Brogan

XenForo moderator
Staff member
#6
Post import, will it be possible to override the formatting stripping you've implemented @Mike?
So that formatting from Word is preserved.

I think that's what Stuart's main query is.
 

Stuart Wright

Well-known member
#7
I'll direct Jake to this thread. I'm guessing that any processing at the time of the import will slow it down, so it's a task better done post import.
Thank you.
 

Brogan

XenForo moderator
Staff member
#8
Be aware that after you convert, you will no longer be able to compose in Word and then post in the editor as a lot of the formatting is stripped (deliberately).