• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 500 server error

Lexy

Active member
#1
When try install plugin gives methis error

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

My host says to check permission folders, any suggestions??
 

Lexy

Active member
#2
also both recomended folders are set to 777, and i check all files for errors and its ok, server log nothing in there???One more thing files inside 777 folders got settings for 775/644??
 

Chris D

XenForo developer
Staff member
#3
When you change the chmod settings to 777 ensure you have the option selected to recursively apply that to all files and sub directories also. internal_directory and data and all their contents should be 777.

That being said, this is highly unlikely to be the cause.

The reason nothing is logged in the Server Error log is because this is happening at the web server before XenForo code is executing. Unfortunately your host has fobbed you off.

This is a 500 Internal Server Error. More details will be logged in the web server's logs. If you do not have access to these, then only your host can look at them and advise you what the errors are.
 

Lexy

Active member
#11
PHP:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default


    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
 

Lexy

Active member
#13
My host provider add this ones, becouse i have problems with 500 server error when try install plugins, i dont know what is change it but i got this ones from yesterday

PHP:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default

<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 

Chris D

XenForo developer
Staff member
#14
If you disable full friendly URLs and rename .htaccess to htaccess.txt do the 500 internal server errors go away?
 

Chris D

XenForo developer
Staff member
#16
If they are disabled, you don't need the .htaccess file, so that would be safe to delete/rename/move (I recommend renaming it to htaccess.txt).

Once you have done that, do add-on installs work?
 

Lexy

Active member
#17
yes i just try install widget framework and got 500 error, but plugin its not install properly option page for list widget, add widget and import widget are blank/empty
 

Chris D

XenForo developer
Staff member
#18
Then the issue is nothing at all to do with htaccess so your host has no reason to make changes there.

Have they looked at the error logs for you yet?
 

Lexy

Active member
#20
my host answer me about this:

On some folders of you they are some .htaccess files , they can cause the problem. Please inform us when you get info about this. We will get you back on the other server you have the problem with news.

so my question its i delete htacces from public_html and leave only ones with text, so becouse i dont use full friendly URLs, it is any other htaccess files inside folders.