1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

500 Internal Server Error

Discussion in 'Server Configuration and Hosting' started by Jesper32, Mar 5, 2016.

  1. Jesper32

    Jesper32 Member


    I'm on a fresh server. I upload the files as required, set permissions on "Data" and Internal Data" to 777. But when I navigate to domain.com/install I get an immediate "500 Internal Server Error", what the heck could be wrong?

    I haven't edited any files.

    I had the excact same server setup, just with a previous domain, as I wanted to test the server before I moved my main domain, this worked fine. After I moved my main domain to this new host, all I get is this "500 Internal Server Error"

    Any suggestions as to what could be causing this.

    Thanks in advance
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Check the server error log - it should have entries which may help to identify the cause.
  3. Jesper32

    Jesper32 Member

    I did check the server error log in CPanel, but there is no log entries regarding this. Only error is a missing folder, that was linked previously
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Is logging enabled?

    I would expect something for a 500 error.

    Without it, it's impossible to say what's causing it as it's a generic error.
  5. Jesper32

    Jesper32 Member

    I suppose so, as I can see those previous error messages.
    But it's very strange as I already had it working with another domain, but after my host changed my server domain, I'm getting this error.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    What is the URL?
  7. Jesper32

    Jesper32 Member

    I have transferred xenforo so it links to there, so it should just be eryger.com/install to begin the installation
  8. Brogan

    Brogan XenForo Moderator Staff Member

    It's throwing a 500 error for the root domain for me.

    I checked the browser console on the chance that there may have been something, but as I expected, there's nothing.

    The only way to know what's happening would be from the error log entries.
  9. Jesper32

    Jesper32 Member

    Thanks for checking. Yes eryger.com is the root domain.
    I deleted everything in my public_html and uploaded the folders and files one by one.

    Now I can see something in the errorlog.
    The first I get are these

    Sat Mar 05 12:25:20.659011 2016] [access_compat:error] [pid 681063] [client my.ip.address:60371] AH01797: client denied by server configuration: /home/erygerco/public_html/library/
    [Sat Mar 05 12:25:20.658144 2016] [access_compat:error] [pid 681063] [client my.ip.address:60371] AH01797: client denied by server configuration: /home/erygerco/public_html/internal_data/

    Also when I upload the index.php file, thats when the server error appears.
  10. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have an .htaccess file in the root?
  11. Jesper32

    Jesper32 Member

    Yes, but just the unedited one that comes with the xenforo installation
  12. Brogan

    Brogan XenForo Moderator Staff Member

    Then it's down to server configuration and you're going to have to troubleshoot it on the server.
  13. Mike

    Mike XenForo Developer Staff Member

    To potentially help troubleshooting, it seems to be failing on any PHP file. http://eryger.com/htaccess.txt works but http://eryger.com/rgba.php doesn't. The latter is an incredibly simple file -- no includes, no database access -- so it works as a good baseline test. Your host may have better error logging details.
  14. Jesper32

    Jesper32 Member

    Thanks Brogan and Mike

    I have been in contact with my host in hope, that they might be able to help. They asked if my xenforo installation was complete and if xenforo was domain specific. The latter I wasn't sure about, so I checked my xenforo license, and at least that is registered to my domain, so I guess that it is?

    But they are extremely slow to reply and I'm almost positive that they will blame this on me, lol
  15. Mike

    Mike XenForo Developer Staff Member

    It's domain specific in that it's connected to your license which is connected to that domain. It isn't explicitly tied to the domain though. The rgba.php file I gave as an example is probably an easy test for them because is has 0 external dependencies. If that's not working, it's pretty much saying PHP has a problem.

    Unfortunately, if they're that slow to respond, it might be worth considering a different host (before you get too ingrained).
  16. Brogan

    Brogan XenForo Moderator Staff Member

    It's unrelated to the XF license or your customer account.
    It's purely a PHP/server configuration issue.
  17. Jesper32

    Jesper32 Member

    I forwarded this information to them, thanks a lot Mike.

    As a test, I just bought a small webspace at another host, with another domain (eryger.eu), and tried to do the installation from there with the same files, and this obviously worked flawlessly.
  18. Jesper32

    Jesper32 Member

    Are there any hosts that you guys can recommend?
  19. Brogan

    Brogan XenForo Moderator Staff Member

    We don't recommend any in particular - it really depends on your requirements and how much you're willing to spend.
  20. WSWD

    WSWD Well-Known Member

    If you're using an old Apache version, that error generally means there are Allow from and Deny from directives that are preventing access.

    If you're > Apache 2.2 or so, the Allow/Deny directives have been replaced with Require directives.

    <Directory"your directory here">
    Options Indexes Blah Blah Blah
    AllowOverride All
    Require all granted

    That would likely also explain why it works with one host vs. another. The one where it works is likely running an outdated version of Apache.

Share This Page