• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 500 Internal Error

#1
Hello!

My forum has been inaccessible since I woke up. The site is https://lumineboreali.net/.
I tried searching for the same problem but found no solutions that seemed applicable for my situation (file permissions are all OK).

Here's my .htaccess:

Code:
#       Mod_security can interfere with uploading of content such as attachments. If you
#       cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
        #SecFilterEngine Off
        #SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default

<IfModule mod_rewrite.c>
        RewriteEngine On

        #       If you are having problems with the rewrite rules, remove the "#" from the
        #       line that begins "RewriteBase" below. You will also have to change the path
        #       of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo

        #       This line may be needed to enable WebDAV editing with PHP as a CGI.
#       RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
</IfModule>

# Hard redirect to main site
RewriteCond %{HTTP_HOST} !^lumineboreali\.net$ [OR]
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteRule ^.*$ https://lumineboreali.net%{REQUEST_URI} [L,R=301]
Any help is extremely appreciated!
 

vbuser

Active member
#2
You need error logs. Look up your IP then try viewing your forum. Can you access your admin page? If you have access to your error log it should say something with your IP. Ask your host for help if needed. That would be a start anyways.
 
#3
You need error logs. Look up your IP then try viewing your forum. Can you access your admin page? If you have access to your error log it should say something with your IP. Ask your host for help if needed. That would be a start anyways.
I'm not finding anything that seems to be relevant in the access logs, but the error log is filled with this message:

[Sun Nov 02 09:14:50.509708 2014] [:error] [pid 88868:tid 34394628096] [client 172.17.0.144:13786] End of script output before headers: index.php

I can't access my XF admin page :/