1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

404s after moving the forum from root to /webmaster/

Discussion in 'Server Configuration and Hosting' started by dojo, Dec 30, 2013.

  1. dojo

    dojo Active Member

    Hello,
    I decided to move the forums from topadmin.net to topadmin.net/webmaster. Have moved the files to the proper location and also set the new board URL prior to moving them. I have cleared the forum cache, even restarted the server (have a VPS).

    If I go to the admin section it works OK on the new URL, but the SEO friendly URLs give me errors. Here is my .htaccess.

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    
    #    cannot attach files, remove the "#" from the lines below.
    
    #<IfModule mod_security.c>
    
    #    SecFilterEngine Off
    
    #    SecFilterScanPOST Off
    
    #</IfModule>
    
    
    
    ErrorDocument 401 default
    
    ErrorDocument 403 default
    
    ErrorDocument 404 default
    
    ErrorDocument 500 default
    
    RewriteEngine On
    
    RewriteBase /
    
    #RewriteCond %{HTTP_HOST} ^www.topadmin.net [NC]
    
    #RewriteRule ^(.*)$ http://topadmin.net/$1 [L,R=301]
    
    <IfModule mod_rewrite.c>
    
        RewriteEngine On
    
    
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
    
        #    line that begins "RewriteBase" below. You will also have to change the path
    
        #    of the rewrite to reflect the path to your XenForo installation.
    
        #RewriteBase /xenforo
    
    
    
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
    
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
    
        RewriteCond %{REQUEST_FILENAME} -l [OR]
    
        RewriteCond %{REQUEST_FILENAME} -d
    
        RewriteRule ^.*$ - [NC,L]
    
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    
        RewriteRule ^.*$ index.php [NC,L]
    
    </IfModule>
    Should I change the base to contain the /webmaster directory too? Or have I messed up otherwise?
    Thank you in advance for any hints.
     
  2. nodle

    nodle Well-Known Member

    I believe this:

    Code:
    RewriteEngine On
    
    RewriteBase /
    
    #RewriteCond %{HTTP_HOST} ^www.topadmin.net [NC]
    
    #RewriteRule ^(.*)$ http://topadmin.net/$1 [L,R=301]
    Needs to be at the top of the .htaccess file.

    Just checked mine. Mine is like this:

    Code:
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^mysite.com [NC]
    RewriteRule ^(.*)$ http://www.mysite.com/$1 [L,R=301]
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    
    See if placing it at the top of the .htaccess file fixes it.
     
    Last edited: Dec 30, 2013
  3. Tracy Perry

    Tracy Perry Well-Known Member

    Check your RewriteBase.
    Are you serving another site off your topadmin.net?
    I think (tho' I no longer use Apache) you need to put RewriteBase to /webmaster
     
  4. nodle

    nodle Well-Known Member

    Mine is on the root so @Tracy Perry may be correct.
     
  5. dojo

    dojo Active Member

    OK, I did it. If it helps others in my situation:
    I moved the rewrite base in the top, as advised and changed it from

    RewriteBase /

    to

    RewriteBase /webmaster

    THANK YOU for your fast support. Let's hope no more issues will arise ;)
     
    Last edited: Dec 30, 2013
    Tracy Perry likes this.
  6. nodle

    nodle Well-Known Member

    Glad to see you got it working. :)
     
    behradj likes this.

Share This Page