1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 2 Server Errors - Watched Forums

Discussion in 'Troubleshooting and Problems' started by BossHaug, Oct 22, 2013.

  1. BossHaug

    BossHaug New Member

    Hey, I just noticed I have to server errors and I cant seem to figure out what is causing the issues. They occur when someone clicks on the watched forums.
    http://www.badprox.com/forums/index.php?watched/forums

    Heres the first one
    Code:
    Error Info
    ErrorException: Invalid argument supplied for foreach() - library/XenForo/ViewPublic/Watched/Forums.php:29
    Generated By: Ders, 2 minutes ago
    Stack Trace
    #0 /home/content/32/11650632/html/forums/library/XenForo/ViewPublic/Watched/Forums.php(29): XenForo_Application::handlePhpError(2, 'Invalid argumen...', '/home/content/3...', 29, Array)
    #1 /home/content/32/11650632/html/forums/library/XenForo/ViewRenderer/Abstract.php(227): XenForo_ViewPublic_Watched_Forums->renderHtml()
    #2 /home/content/32/11650632/html/forums/library/XenForo/ViewRenderer/HtmlPublic.php(67): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Html', Array, 'watch_forums')
    #3 /home/content/32/11650632/html/forums/library/XenForo/FrontController.php(572): XenForo_ViewRenderer_HtmlPublic->renderView('XenForo_ViewPub...', Array, 'watch_forums', NULL)
    #4 /home/content/32/11650632/html/forums/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_HtmlPublic), Array)
    #5 /home/content/32/11650632/html/forums/index.php(13): XenForo_FrontController->run()
    #6 {main}
    Request State
    array(3) {
    ["url"] => string(54) "http://www.badprox.com/forums/index.php?watched/forums"
    ["_GET"] => array(1) {
    ["watched/forums"] => string(0) ""
    }
    ["_POST"] => array(0) {
    }
    }
    
    And number 2
    Code:
    Error Info
    ErrorException: Undefined index: nodeParents - library/XenForo/ViewPublic/Watched/Forums.php:21
    Generated By: Ders, 6 minutes ago
    Stack Trace
    #0 /home/content/32/11650632/html/forums/library/XenForo/ViewPublic/Watched/Forums.php(21): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/content/3...', 21, Array)
    #1 /home/content/32/11650632/html/forums/library/XenForo/ViewRenderer/Abstract.php(227): XenForo_ViewPublic_Watched_Forums->renderHtml()
    #2 /home/content/32/11650632/html/forums/library/XenForo/ViewRenderer/HtmlPublic.php(67): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Html', Array, 'watch_forums')
    #3 /home/content/32/11650632/html/forums/library/XenForo/FrontController.php(572): XenForo_ViewRenderer_HtmlPublic->renderView('XenForo_ViewPub...', Array, 'watch_forums', NULL)
    #4 /home/content/32/11650632/html/forums/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_HtmlPublic), Array)
    #5 /home/content/32/11650632/html/forums/index.php(13): XenForo_FrontController->run()
    #6 {main}
    Request State
    array(3) {
    ["url"] => string(54) "http://www.badprox.com/forums/index.php?watched/forums"
    ["_GET"] => array(1) {
    ["watched/forums"] => string(0) ""
    }
    ["_POST"] => array(0) {
    }
    }
    
    What should I do?
     
  2. BossHaug

    BossHaug New Member

Share This Page