1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed 1.2 - Signature - Links require http:// but it's not required in regular posts

Discussion in 'Resolved Bug Reports' started by CyclingTribe, Jun 19, 2013.

  1. CyclingTribe

    CyclingTribe Well-Known Member

    When editing my signature I clicked the link icon and entered www.clickfinity.net but it didn't create the link (even after saving).

    I tried again with the http:// added and it linked okay.

    However, when I was testing this same behaviour in a thread post it seemed to link without the http:// - so there appears to be some inconsistency in the formatting of a link the two will accept.

    Cheers,
    Shaun :D
     
  2. James

    James Well-Known Member

    I've just tried the following steps:
    Edit Signature
    Click Link
    Insert 'www.clickfinity.net'

    It autolinked fine on Chrome, Win7.
     
  3. CyclingTribe

    CyclingTribe Well-Known Member

    Win 8 - FF21 - Steps to repeat (for me):
    • Username > Signature
    • Type into signature editor - CycleChat
    • Highlight and click link icon
    • type - www.cyclechat.net (no http://)
    • Press enter / click Insert
    • Save
    Not linked.
     
  4. James

    James Well-Known Member

    Ah, I can confirm it doesn't work using those steps too.
     
    CyclingTribe likes this.
  5. Divvens

    Divvens Well-Known Member

    Cannot reproduce the same with Windows 7 Chrome 27.0.1453.116/ Firefox 21.

    Edit: Double checked, followed the steps exactly, it links fine here.
    LinkScreenshot.png
     
    Last edited: Jun 20, 2013
  6. CyclingTribe

    CyclingTribe Well-Known Member

    TBH I think there are a few auto-parsing link issues with the editor at the moment that may be responsible for what I'm seeing.

    There seems to have been some change whereby the editor automatically creates links as you edit (as opposed to when you finally hit 'Post') but it's not working consistently; for example, I've twice had the editor point-blank refuse to create a link using the icon button (and had to manually add the link BBCode) - but I simply cannot get it to do this behaviour in a repeatable manner so cannot report it. :(
     
    Divvens likes this.
  7. Mike

    Mike XenForo Developer Staff Member

    I'm not able to reproduce this. Can you still confirm this here?

    If so, can you be specific what you're selecting? (Where you do you click and where do you end the drag, as specifically as possible? Screenshots or video may help.)
     
  8. James

    James Well-Known Member

    What I do is:
    Click inside RTE
    Type in my word (I used CycleChat)
    Selected all (Ctrl + A) with cursor on right-hand side.
    Click link icon
    Enter URL beginning www
    Save

    RTE shows no visible sign of hyperlinking, switching to plain editor shows no URL BB Code and saving saves it as plain text.
     
  9. Mike

    Mike XenForo Developer Staff Member

    It's the ctrl+a. It doesn't have anything to do with the contents of the link as far as I can see.
     
    CyberAP likes this.
  10. James

    James Well-Known Member

    Ha.. I've just tried it with the http prepended and it doesn't link whatsoever in the signature (for me anyway).

    Same method as above except I tried manually highlighting it from left to right and right to left.
     
  11. Martok

    Martok Well-Known Member

    I've just replicated this issue.

    I tried it with Senior Gamers as the only text in my signature. I then selected it and added the URL. It didn't link the text.

    I then tested the same thing but with some text on the first line and Senior Gamers on the second line. That time the link worked.
    A further test and I put a single character on the first line followed by a space, followed by Senior Gamers. The link worked.

    So it seems the issue is when the link is right at the beginning of the signature.
     
  12. CyclingTribe

    CyclingTribe Well-Known Member

    Tried again and still the same odd behaviour of not creating the link; both here in this reply (test text deleted) and the signature itself. Sorry @Mike. :(
     
  13. Mike

    Mike XenForo Developer Staff Member

    You know, I don't seem to be able to reproduce this any more. I wonder if it's been fixed in FF 22?

    If you can reproduce it, can you confirm your FF version? (Try the latest version if you're not running it too.)
     
    Divvens likes this.
  14. CyclingTribe

    CyclingTribe Well-Known Member

    It's still a problem, but a slightly different one. After some more experimenting (Win 7 - FF 22) I've figured out how to reproduce it consistently (and the lack of http:// is a red herring):
    • Username > Signature
    • Type some text into the editor
    • Highlight some of the text
    • Click link icon
    • Type a URL
    • Press the enter key / click Insert
    It's pressing the enter key (from the URL overlay) that causes it not to link - clicking the Insert button works every time and creates the link as expected.

    Let me know if anyone else can reproduce this and the OS / browser combination you're using.

    Cheers,
    Shaun :D
     
  15. Kier

    Kier XenForo Developer Staff Member

    I can reproduce this using the steps you described, using FF 22 / Mac OS, though Chrome and Opera are fine.

    It's not limited to the signature editor - I've reproduced it on quick reply and the full reply editor.
     
    IcEWoLF, shenmuee and CyclingTribe like this.
  16. Mike

    Mike XenForo Developer Staff Member

    Totally bizarre. I have worked around this now though. Please confirm here.
     
    IcEWoLF and shenmuee like this.
  17. CyclingTribe

    CyclingTribe Well-Known Member

    Tested and now working as expected. Fixed! (y)
     
    IcEWoLF and shenmuee like this.

Share This Page