• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed (1.2 Beta 5) Paid Subscription Error

0ptima

Well-known member
#1
Got the following error when importing paid subscriptions from VB 3.8

Server Error

Mysqli statement execute error : Out of range value adjusted for column 'length_amount' at row 1

Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1612
XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1601
XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1393
XenForo_DataWriter->save() in XenForo/Model/Import.php at line 591
XenForo_Model_Import->_importData() in XenForo/Model/Import.php at line 969
XenForo_Model_Import->importUserUpgradeDefinition() in XenForo/Importer/vBulletin.php at line 1477
XenForo_Importer_vBulletin->stepPaidSubscriptions() in XenForo/Importer/Abstract.php at line 77
XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 180
XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 232
XenForo_ControllerAdmin_Import->_startStep() in XenForo/ControllerAdmin/Import.php at line 175
XenForo_ControllerAdmin_Import->actionStartStep() in XenForo/FrontController.php at line 337
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /home/public_html/xf/admin.php at line 13
 

Mike

XenForo developer
Staff member
#2
Just out of curiosity, did you have a subscription length with a number value > 255? What did you set?

Our structure only supports a max of 255 for that, so it will have to be capped (which is now fixed).
 

0ptima

Well-known member
#3
I remember vaguely changing the length of the description of the paid sub shown to the user (IE I added more info on what they were getting). Could that be the issue?
 

Mike

XenForo developer
Staff member
#5
No, not the data -- the length of the subscription itself. Did you enter it as "365 days" instead of "1 year", for example?