1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MG 1.1 1.1.7 install error

Discussion in 'Media Gallery Support' started by HWS, Jun 2, 2016.

  1. HWS

    HWS Well-Known Member

    When upgrading from 1.1.2 to 1.1.7 we alwys get the following error when running the XML:
    Code:
    Callback XenGallery_Listener::extendConvMessageDataWriter is invalid (Invalid Method)
    How can we solve that?
     
  2. HWS

    HWS Well-Known Member

    After trying again (5st time), the error is now:
    Code:
    Developer: default_value is not a valid array (xengalleryVideoUploadConstraints)
    The upgrade does not finish successfully.
     
  3. Mike

    Mike XenForo Developer Staff Member

    There's a weird mix going on here. The first error would imply a newer XML but the second error would imply an older one. The latter one makes me think you were trying to import the 1.1.2 XML which isn't compatible with the latest version of XF.

    The first error would imply that the other files haven't been uploaded properly (the 1.1.7 version) or old versions are being held in the opcode cache. I'd try a reupload first.
     
  4. HWS

    HWS Well-Known Member

    I always use the XML from the add-ons folder at the server. The file has been updated, I checked that.

    Also already reuploaded....

    But thanks, I'll try again. XFRM update went smoothly.
     
  5. Chris D

    Chris D XenForo Developer Staff Member

    Are you manually uploading the files and browsing for the XML or are you using any sort of automated installation process?
     
  6. HWS

    HWS Well-Known Member

    Manually uploading and using the XML from the server.

    I was now able to successfully finish the update. Thanks for help!
     
  7. TWOKam

    TWOKam Member

    Hi HWS - how did you manage to finish the upgrade?

    I'm having the same problem as the first message, I'm upgrading from 1.1.4 to the latest one. I've tried re-uploading the files 3 times but I still keep getting the same error.
     
  8. TWOKam

    TWOKam Member

    I gave up on this and ended up upgrading XenForo Enhanced Search then did the forum from 1.5.7 to 1.5.8. I thought I'd try the gallery .xml file again after that and it upgraded (I didn't reupload it) . All done now.
     

Share This Page