1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Service Issue 1.0.4: IE9 - Google +1 button disappears (Forums)

Discussion in 'Resolved Bug Reports' started by soloarquitectura, Jul 13, 2011.

  1. soloarquitectura

    soloarquitectura Active Member

    See image (Xenforo.com):

    1.jpg

    You need to press F5 to display it.
     
  2. ankurs

    ankurs Well-Known Member

    it works fine, just loads a bit late
     
  3. Lawrence

    Lawrence Well-Known Member

    I don't believe it is a XenForo bug, but a Google issue. Google's +1 already has over 10 million signed up users and that number is increasing in leaps and bounds daily.
     
  4. soloarquitectura

    soloarquitectura Active Member

    Not for me. I need to press F5.
     
  5. CurveGotti

    CurveGotti Active Member

    Works just fine for me, doesn't load slow, and I don't need to refresh to see it, I think Lawrence is right it was probably just something with google at the time you tried, or perhaps an addon in your browser?
     
  6. soloarquitectura

    soloarquitectura Active Member

    I have no add-ons in my browser (Flash only) and occurs permanently.
    It also happens with Flash disabled.
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    I have the same problem with a vanilla build of IE9.

    We did some quick debugging yesterday to see if it was related to the mega footer, but apparently not.
     
  8. Dark Matter

    Dark Matter Active Member

    This Google +1 is more trouble than it's worth. I wouldn't mind, but it's not even fast at loading up and only helps slows things down.
     
  9. soloarquitectura

    soloarquitectura Active Member

    More info:
    The problem is specific to IE9 (9.0.8112.16421).
    Tested on three different computers (Windows 7 x32 & x64) and different times.
    Chrome (12.0.742.122) works fine.
     
  10. soloarquitectura

    soloarquitectura Active Member

    I solved this problem by adding the following line at the end of the template google_analytics:
    Code:
    <script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
    It's a provisional solution, but it solves the issue. :)
     
  11. Mike

    Mike XenForo Developer Staff Member

    Is this still happening? Google rolled out a supported asynchronous version of the +1 button, so any issue on their end really should be fixed.
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    Still not showing for me without a refresh here on xenforo.com only.
     
  13. soloarquitectura

    soloarquitectura Active Member

    Yes :(

    +1
     
  14. CyclingTribe

    CyclingTribe Well-Known Member

    +1 for me on IE9 too.

    Also happening at GeeksChat with Flexile skin.
     
  15. HoddzDJ

    HoddzDJ Active Member

    I also cannot see the +1 button on any xenforo installations when browsing using my iPad. I will try adding that code Soloarquitectura has added and see what happens!
     
  16. HoddzDJ

    HoddzDJ Active Member

    Added the code and nothing changed. I also noticed that once I did load up my forums on my iPad, I only got access to the Tweet button; no Facebook button or Google +1 so I'm not sure if I need to alter something that has been posted somewhere else on this board somewhere! I sure hope it is fixed for all browsers soon or in a future release which I have no doubt that it will be.
     

Share This Page