1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[SolidMean] Longer Page Titles 1.0.0

No more 50 character limit!

Tags:
  1. SneakyDave
    Compatible XF Versions:
    • 1.3
    • 1.4
    • 1.5
    License:
    http://sneakydave.com/community/products/license-agreement
    Visible Branding:
    No
    [​IMG]
    If this addon is useful to you, please consider donating any amount.​


    ABOUT
    This is a small add-on, requested by @Andy.N, that allows a page title length to be set to 120 characters, rather than the default of 50.

    In order to do this, the add-on changes the size of the 'title' column in the 'xf_node' table from VARCHAR(50) to VARCHAR(120). It then changes the getFields() method for the DataWriter Page class to allow a maxmium length of 120 characters.

    Because this addon modifies the xf_node table, it is highly encouraged that you make a backup of your forum database before installing this addon.

    This addon only affects page titles. Although the node title column is changed to 120 characters, forum titles are still limited to 50 characters. This was done to limit the impact to any addons expecting forum titles to be no longer than 50 characters.

    I make no guarantees of the usefulness of this addon. This addon adds no branding, and has no callbacks to third party applications or servers.

    INSTALLATION:
    - Upload contents of Upload folder to XenForo root directory, overwriting any existing files.
    - Install addon-sm_LongerPageTitles.xml file.

    There are no options to set, but there is one empty option listed that describes what this addon does.

    UNINSTALLING
    Uninstalling this add-on will try to revert the 'title' column in the 'xf_node' to the default of VARCHAR(50). If you uninstall this addon, and you still have page titles greater than 50 characters, you may receive a server error or warning that the column was truncated, and the table change may not execute. In that case, it is strongly encouraged that you run this query against your database to change the column back to a 50 character limit.

    Code:
    ALTER TABLE `xf_node` CHANGE `title` `title` VARCHAR(50);
    
    wagamata likes this.