1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Zend_Mail_Transport_Exception: Email to xxx failed: Unable to send mail. mail

Discussion in 'Troubleshooting and Problems' started by Tealk, Oct 29, 2014.

  1. Tealk

    Tealk Active Member

    I get this error on my Bord i have host it on one.com, this are the server specs, can one say me how i can fix this or can i ignore this?

    Code:
    Server Error Log
    Error Info
    Zend_Mail_Transport_Exception: Email to xxx failed: Unable to send mail. mail(): Policy restriction in effect. The fifth parameter is disabled on this system - library/Zend/Mail/Transport/Sendmail.php:137
    Generated By: Unknown Account, Today at 7:12 AM
    Stack Trace
    #0 /customers/3/c/5/terrifying-nightmare.com/httpd.www/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
    #1 /customers/3/c/5/terrifying-nightmare.com/httpd.www/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #2 /customers/3/c/5/terrifying-nightmare.com/httpd.www/library/XenForo/Model/MailQueue.php(71): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
    #3 /customers/3/c/5/terrifying-nightmare.com/httpd.www/library/XenForo/Deferred/MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(7.9999990463257)
    #4 /customers/3/c/5/terrifying-nightmare.com/httpd.www/library/XenForo/Model/Deferred.php(256): XenForo_Deferred_MailQueue->execute(Array, Array, 7.9999990463257, '')
    #5 /customers/3/c/5/terrifying-nightmare.com/httpd.www/library/XenForo/Model/Deferred.php(390): XenForo_Model_Deferred->runDeferred(Array, 7.9999990463257, '', false)
    #6 /customers/3/c/5/terrifying-nightmare.com/httpd.www/library/XenForo/Model/Deferred.php(335): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #7 /customers/3/c/5/terrifying-nightmare.com/httpd.www/deferred.php(23): XenForo_Model_Deferred->run(false)
    #8 {main}
    Request State
    array(3) {
    ["url"] => string(48) "http://www.terrifying-nightmare.com/deferred.php"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(43) "/index.php?conversations/add&to=Zoy+%2F+Dom"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
    }
    }
    
    
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    The error seems to indicate that the specific server configuration is incompatible with the sendmail function.

    I suspect you may need to contact your host about that to check whether they can change it.
     
  3. Mike

    Mike XenForo Developer Staff Member

    You can disable the "-f" parameter option to get around that, but disabling the parameter like that may lead to lower deliverability.
     
    Brogan likes this.
  4. Tealk

    Tealk Active Member

    the support doesn't know what he should do
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    As Mike said, uncheck this.

    upload_2014-10-29_12-15-11.png
     
  6. Tealk

    Tealk Active Member

    what does this option?
     
  7. OldCoals

    OldCoals Active Member

    I am getting the same issues randomly, with the -f option enabled.
     

Share This Page