• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Zend_Mail_Protocol_Exception: 4.1.3 Bad recipient address syntax

dieg0

Active member
#1
I just started getting a bunch these in my error log. Same _xfRequestUri in all of them.

Server Error Log
Error Info
Zend_Mail_Protocol_Exception: 4.1.3 Bad recipient address syntax - library/Zend/Mail/Protocol/Abstract.php:431
Generated By: Cuenta desconocida, Hace 13 minutos
Stack Trace
#0 /webs/mysite.com/library/Zend/Mail/Protocol/Smtp.php(289): Zend_Mail_Protocol_Abstract->_expect(Array, 300)
#1 /webs/mysite.com/library/Zend/Mail/Transport/Smtp.php(211): Zend_Mail_Protocol_Smtp->rcpt('tornadoblackout...')
#2 /webs/mysite.com/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#3 /webs/mysite.com/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#4 /webs/mysite.com/library/XenForo/Model/MailQueue.php(62): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
#5 /webs/mysite.com/library/XenForo/Deferred/MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(9.9999990463257)
#6 /webs/mysite.com/library/XenForo/Model/Deferred.php(208): XenForo_Deferred_MailQueue->execute(Array, Array, 9.9999990463257, '')
#7 /webs/mysite.com/library/XenForo/Model/Deferred.php(331): XenForo_Model_Deferred->runDeferred(Array, 9.9999990463257, '', false)
#8 /webs/mysite.com/library/XenForo/Model/Deferred.php(284): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#9 /webs/mysite.com/deferred.php(18): XenForo_Model_Deferred->run(false)
#10 {main}
Solicitar estado
array(3) {
["url"] => string(35) "http://www.mysite.com/deferred.php"
["_GET"] => array(0) {
}
["_POST"] => array(4) {
["_xfRequestUri"] => string(43) "/conversations/torneo-pokemon.985421/page-3"
["_xfNoRedirect"] => string(1) "1"
["_xfToken"] => string(8) "********"
["_xfResponseType"] => string(4) "json"
}
}
 
Last edited:

Mike

XenForo developer
Staff member
#2
The email appears to be to an address that starts with "tornadoblackout" - if you look that user up, do you see anything of note in their email? (Something different from normal)

If this spontaneously started happening and is for a lot of different users, it may be an issue with your SMTP server rejecting emails that it probably shouldn't.
 

dieg0

Active member
#3
It only happens with one user who uses tornadoblackoutXXX@.hotmail.com as his email address.

I'm guessing it has something to do with that .?
 

Adam Howard

Well-known member
#5
/admin.php?users/search

Search for (via email)

@.
@..
@@
@@.
@@..

If anything comes up under those search.... Delete them.

There was a very powerful spam bot that affected other developments, that hit some sites a few years back (hit everyone at once, at the same time). I have noticed this when importing a few people away from those other forum developments.
 
Last edited:

OperaManiac

Well-known member
#6
I am getting this on my board:



The email address in user profile appears to be correctly formatted:



Just putting it here coz this is the only thread that mentions this error.