XPress - A theme and bridge for bringing WordPress into XenForo

XPress - A theme and bridge for bringing WordPress into XenForo 1.1.4

No permission to buy ($299.95)

Lukas W.

Well-known member
It seams that WP supports it under the hood... take a look here:
Partially. The database and some parts of the code support it, but their dashboard and some other parts do not. Aside from that, stock roles are strictly hierarchical, so there is no direct need either, and we'd rather not build in something that eventually leads to troubles.
 

PeteMarko

Member
I just tried the registration process using an alias which I needed to do to test the process not only for Xpress but for my Wordpress site.

I think I have just realized, single sign-on refers to users already registered on the platform or the forum. It has nothing to do with registration, in other words, I need to register my alias with the forum as well as Wordpress correct?
 

t_chance

Member
@Lukas W. -

Hitting these errors with a fresh install of latest xlink/xpress.

I've uninstalled, reinstalled - manually and from archive. These seem to be a bit different than post #974. Maybe not though.

Any thoughts on how to correct these issues?

When trying to save updates to platform
Code:
Exception: in src/addons/ThemeHouse/XPress/RemoteHandler/Traits/APICall.php at line 83
ThemeHouse\XPress\RemoteHandler\Platform->callAPI() in src/addons/ThemeHouse/XPress/RemoteHandler/Platform.php at line 49
ThemeHouse\XPress\RemoteHandler\Platform->syncSettingsToRemote() in src/addons/ThemeHouse/XLink/Admin/Controller/Platform.php at line 164
ThemeHouse\XLink\Admin\Controller\Platform->actionSave() in src/XF/Mvc/Dispatcher.php at line 321
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 244
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 100
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 50
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2177
XF\App->run() in src/XF.php at line 390
XF::runApp() in admin.php at line 13

When attempting to delete a Platform
Code:
Exception: in src/addons/ThemeHouse/XPress/RemoteHandler/Traits/APICall.php at line 83
ThemeHouse\XPress\RemoteHandler\Platform->callAPI() in src/addons/ThemeHouse/XPress/RemoteHandler/Platform.php at line 178
ThemeHouse\XPress\RemoteHandler\Platform->_delete() in src/addons/ThemeHouse/XLink/RemoteHandler/AbstractPlatform.php at line 100
ThemeHouse\XLink\RemoteHandler\AbstractPlatform->delete() in src/addons/ThemeHouse/XLink/Admin/Controller/Platform.php at line 185
ThemeHouse\XLink\Admin\Controller\Platform->actionDelete() in src/XF/Mvc/Dispatcher.php at line 321
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 244
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 100
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 50
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2177
XF\App->run() in src/XF.php at line 390
XF::runApp() in admin.php at line 13

Pulling up linked users
Code:
Exception: in src/addons/ThemeHouse/XPress/RemoteHandler/Traits/APICall.php at line 83
ThemeHouse\XPress\RemoteHandler\Account->callAPI() in src/addons/ThemeHouse/XPress/RemoteHandler/Account.php at line 126
ThemeHouse\XPress\RemoteHandler\Account->findRemoteAccounts() in src/addons/ThemeHouse/XLink/Admin/Controller/Platform.php at line 280
ThemeHouse\XLink\Admin\Controller\Platform->actionUsers() in src/XF/Mvc/Dispatcher.php at line 321
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 244
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 100
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 50
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2177
XF\App->run() in src/XF.php at line 390
XF::runApp() in admin.php at line 13
 

Lukas W.

Well-known member
There's likely a second exception logged in the ACP error log. In short, XLink hasn't been able to make a connection to your WordPress installation for one of many reasons. Maybe you put the wrong URL, your WordPress installation has restricted access or resides behind a proxy?
 

t_chance

Member
There's likely a second exception logged in the ACP error log.
Is there anything in particular from the error log that would help identify the issue? I have 90 errors to choose from.

Maybe you put the wrong URL, your WordPress installation has restricted access or resides behind a proxy?
Checked the URL, and it is correct across the board. How would I determine if my WP installation has restricted access or is behind a proxy?

Thanks for the help, @Lukas W.
 
Last edited:

mmirlach

Active member
Is there the option to link two Wordpress posts to the same Xenforo thread?
I tried to to do it by manually adding the same XF thread ID to the Wordpress post but it get's manually overwritten with a new Thread ID for a newly generated thread.
 

PeteMarko

Member
I think my question might have been missed, does single login refer to an ability to login via Wordpress or the forum which means you are logged on in both, but has nothing to do with registration. When someone registers they need to do it twice, is that correct or?
 

Breixo

Well-known member
@Lukas W. -

Hitting these errors with a fresh install of latest xlink/xpress.

I've uninstalled, reinstalled - manually and from archive. These seem to be a bit different than post #974. Maybe not though.

Any thoughts on how to correct these issues?

When trying to save updates to platform
Code:
Exception: in src/addons/ThemeHouse/XPress/RemoteHandler/Traits/APICall.php at line 83
ThemeHouse\XPress\RemoteHandler\Platform->callAPI() in src/addons/ThemeHouse/XPress/RemoteHandler/Platform.php at line 49
ThemeHouse\XPress\RemoteHandler\Platform->syncSettingsToRemote() in src/addons/ThemeHouse/XLink/Admin/Controller/Platform.php at line 164
ThemeHouse\XLink\Admin\Controller\Platform->actionSave() in src/XF/Mvc/Dispatcher.php at line 321
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 244
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 100
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 50
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2177
XF\App->run() in src/XF.php at line 390
XF::runApp() in admin.php at line 13

When attempting to delete a Platform
Code:
Exception: in src/addons/ThemeHouse/XPress/RemoteHandler/Traits/APICall.php at line 83
ThemeHouse\XPress\RemoteHandler\Platform->callAPI() in src/addons/ThemeHouse/XPress/RemoteHandler/Platform.php at line 178
ThemeHouse\XPress\RemoteHandler\Platform->_delete() in src/addons/ThemeHouse/XLink/RemoteHandler/AbstractPlatform.php at line 100
ThemeHouse\XLink\RemoteHandler\AbstractPlatform->delete() in src/addons/ThemeHouse/XLink/Admin/Controller/Platform.php at line 185
ThemeHouse\XLink\Admin\Controller\Platform->actionDelete() in src/XF/Mvc/Dispatcher.php at line 321
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 244
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 100
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 50
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2177
XF\App->run() in src/XF.php at line 390
XF::runApp() in admin.php at line 13

Pulling up linked users
Code:
Exception: in src/addons/ThemeHouse/XPress/RemoteHandler/Traits/APICall.php at line 83
ThemeHouse\XPress\RemoteHandler\Account->callAPI() in src/addons/ThemeHouse/XPress/RemoteHandler/Account.php at line 126
ThemeHouse\XPress\RemoteHandler\Account->findRemoteAccounts() in src/addons/ThemeHouse/XLink/Admin/Controller/Platform.php at line 280
ThemeHouse\XLink\Admin\Controller\Platform->actionUsers() in src/XF/Mvc/Dispatcher.php at line 321
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 244
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 100
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 50
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2177
XF\App->run() in src/XF.php at line 390
XF::runApp() in admin.php at line 13
Getting a similar error.
Both instalations within the same server without special permissions.
Ticket opened.
 

Andy.N

Well-known member
Pre-sales question:
can this utilize XF 2.1 stock style?
I only want to use this for XF home and pages. I have XF installed on root and WP install in /wp/ folder.
Is there any issue?
Thank you
 

Andy.N

Well-known member
That setup is one of the most preferable ones.
Following up on this, how are the existing urls for xf pages appear now? I have a bunch of pages at site.com/pagexyz. Will it now become site.com/wp/pagexyz?
Would love some examples of how the urls change after this.
 

Spinix-

Active member
I've edited the file /scr/XPress.php in the xPress WP plugin to allow support for custom taxonomies. Example; (I've edited more lines than only that one)
9YFxcJh.png


Could you please add support for custom taxonomies out of the box in the next releases?
any news about this?
 

Sperber

Well-known member
@Mike Creuzer & @Lukas W. ,
I know, you´ll gonna hate me for this, but a man's gotta do what a man's gotta do - or lets call it the curse of good deeds strikes back ;)

Fellows, I had to climb a steep learning curve with WP and there is way to go. Honestly. Avoided to get in contact with WP, whenever I could - and now I´m on the hook. There is one thing with XPress, that meanwhile drives me literally crazy. Just because this would make XPress so much better as it is by now.

XPress utilizes the standard sub-nav, while the drop-down nav shows the categories. I am quite sure you´ve noticed it yourself already, but that makes it somehow hard to navigate on the XPress pages. This morning I read my eNewspaper and - ka ching - instantly knew, with this everyone using it would have that blinking in his eye. Check out, how the sub-nav works on this site: https://www.sueddeutsche.de/

As everyone is trying to utilize XP/WP the best way possible as a news portal, translated to XPress it could look like this:
196820

I´ve already seen WP templates, that use this kind of sub-nav. Lukas, I guess that the work needed for this will weigh on your shoulders - at least when Mike will put it there with a friendly clap - and assume you´re reading this with rolling eyes. But does it help, when I say "Please, please, please" ? ;)
 

mmirlach

Active member
One more question: I've just updated my staging server to the most recent versions of Xlink / Xpress. Everything looks great on first sight but it looks like I'm not able to comment on the Wordpress site anymore (while the forum is properly shown as comments and new XF posts are displayed under articles as well).
Did anyone else experience the same?
 

doublespaces

Well-known member
Maybe I've missed this, but how do you prevent the promotion from modifying the post? I don't want the quotation added with the "Continue reading" text or whatever it says. That rips out all the attachments and ruins the formatting of the forum post.
 
Top