1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XFS Mobile [Deleted]

Discussion in 'Style Releases' started by Russ, Feb 19, 2012.

  1. Russ

    Russ Well-Known Member

    Russ submitted a new resource:

    XFS Mobile (version 1.0) - XenForo Stop Mobile Style

    Read more about this resource...
     
  2. Russ

    Russ Well-Known Member

    Quick Notes:
    • I haven't tried in-depth with major addon's, I'll do be best to get them supported asap.
    • I'm not the best designer, as you might be able to tell
    • I'll do my best to help out when I can
     
    Shelley likes this.
  3. Andy.N

    Andy.N Well-Known Member

    Finally. Thanks for all your hard work, Russ.
     
  4. Dinh Thanh

    Dinh Thanh Well-Known Member

    Thanks Russ,

    How to allow only first level forums can be displayed on Forum Home?
     
  5. Russ

    Russ Well-Known Member

    I went ahead and added this as a style property, but for a quick fix until next version is released:

    Templates -> edit : node_forum_level_2

    Find:

    Code:
    <xen:if is="{$renderedChildren} AND {$level} == 2">
    <xen:foreach loop="$renderedChildren" value="$child">
    <div class="nodemobilesub">
    <img src="styles/xfsmobile/folder_go.png" style="float: left;"><h3 class="nodeTitle">{xen:raw $child}</h3>
        
    </div>
    </xen:foreach>
    </xen:if>
    

    Wrap it in a comment like this or remove it.

    Code:
    <xen:comment>
    <xen:if is="{$renderedChildren} AND {$level} == 2">
    <xen:foreach loop="$renderedChildren" value="$child">
    <div class="nodemobilesub">
    <img src="styles/xfsmobile/folder_go.png" style="float: left;"><h3 class="nodeTitle">{xen:raw $child}</h3>
        
    </div>
    </xen:foreach>
    </xen:if>
    </xen:comment>
    
     
    Dinh Thanh likes this.
  6. Dinh Thanh

    Dinh Thanh Well-Known Member

    I could wait for next version.
    I'm working with Wipe To Go to support your style.
     
    Ranger375 likes this.
  7. Dinh Thanh

    Dinh Thanh Well-Known Member

    It's seem you removed all hooks in PAGE_CONTAINER.
    Working to add JS with page_container_js_body hook.
     
  8. DRE

    DRE Well-Known Member

    Don't wait, do it now, cause Russ be mad busy.
     
    Dinh Thanh likes this.
  9. Russ

    Russ Well-Known Member

    Well this is embarrassing isn't it :), somewhere between the transfer of dev to live, or something it wasn't showing me I had outdated templates, late night boo boo possibly ;p. Fixing now.
     
  10. Russ

    Russ Well-Known Member

    Shelley likes this.
  11. el canadiano

    el canadiano Active Member

    Thanks for the updates, Russ. Much appreciated.
     
  12. Adam Howard

    Adam Howard Well-Known Member

  13. Russ

    Russ Well-Known Member

    Implemented for next version, if you care to fix it yourself, open the template "login"

    Right after:
    Code:
    <xen:if is="!{$visitor.user_id}">
    
    <xen:container var="$hideLoginBar">1</xen:container>
    
    Add this:

    Code:
    
    <div style="text-align: center;">
        <xen:if hascontent="true">
            <ul id="eAuthUnit">
                <xen:contentcheck>
                    <xen:hook name="login_bar_eauth_items">
                    <xen:if is="{$xenOptions.facebookAppId}">
                        <xen:require css="facebook.css" />
                        <li><a href="{xen:link register/facebook, '', 'reg=1'}" class="fbLogin" tabindex="110"><span>{xen:phrase login_with_facebook}</span></a></li>
                    </xen:if>
                    </xen:hook>
                </xen:contentcheck>
            </ul>
        </xen:if>
    </div>
    
    It'll allow facebook/twitter auth(if enabled)
     
    TheVisitors likes this.
  14. DRE

    DRE Well-Known Member

    What prevents members from being able to upload attachments/pictures?
     
  15. Forsaken

    Forsaken Well-Known Member

    File uploads don't work on iOS, not sure if he's removed the portion for attachments or not.
     
  16. Russ

    Russ Well-Known Member

    It's removed
     
    Dinh Thanh likes this.
  17. Dinh Thanh

    Dinh Thanh Well-Known Member

    Hi Russ,
    I have a bug & an idea:

    1. Sub forum display bug (New thread boxes are still exist)
    Screen Shot 2012-02-20 at 12.18.41 PM.png

    2. Idea: use mobile definition for doctype for page_container instead of using fixed 320x viewport.

    <!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.2//EN" "http://www.openmobilealliance.org/tech/DTD/xhtml-mobile12.dtd">
    Then remove meta tag viewport (320px), This help many browsers with different resolutions can adjust width page automatically.

    Thank you.
     
  18. Russ

    Russ Well-Known Member

    Can you PM me your node tree setup for this particular section
     
  19. yavuz

    yavuz Well-Known Member

    Russ thank you for this update. Is there by chance a way to disable XenPorta when swiching to the mobile style? The portal looks really messy when the mobile style is activated...
     
  20. Russ

    Russ Well-Known Member

    XenPorta is first on the list to make it compatible with, except it will be tricky as almost every setup is different. So... as for disabling it, I'll see what I can find out for the best method.

    Not sure if you'd want to do this but you could override the default portal style in the portal options. It should still retain the mobile detect on the actual forums still.
     
    yavuz likes this.

Share This Page