• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XFS Mobile [Deleted]

Russ

Well-known member
#1
Russ submitted a new resource:

XFS Mobile (version 1.0) - XenForo Stop Mobile Style

Hello :), after a well deserved break I managed to update this for 1.1.x.

Be aware this style comes as is, with really no guarantee to fully support it. I'll do my best to help everyone out, just my time is rather limited lately.

I've managed to get a working "mobile style" with as few template edits as possible. I've tried to set it up to allow easy customization with the following:
  • Mobile Style Properties
  • Mobile Navigation/Quick Nav in their own templates
  • Mobile CSS created...
Read more about this resource...
 

Russ

Well-known member
#2
Quick Notes:
  • I haven't tried in-depth with major addon's, I'll do be best to get them supported asap.
  • I'm not the best designer, as you might be able to tell
  • I'll do my best to help out when I can
 

Russ

Well-known member
#5
Thanks Russ,

How to allow only first level forums can be displayed on Forum Home?
I went ahead and added this as a style property, but for a quick fix until next version is released:

Templates -> edit : node_forum_level_2

Find:

Code:
<xen:if is="{$renderedChildren} AND {$level} == 2">
<xen:foreach loop="$renderedChildren" value="$child">
<div class="nodemobilesub">
<img src="styles/xfsmobile/folder_go.png" style="float: left;"><h3 class="nodeTitle">{xen:raw $child}</h3>
    
</div>
</xen:foreach>
</xen:if>

Wrap it in a comment like this or remove it.

Code:
<xen:comment>
<xen:if is="{$renderedChildren} AND {$level} == 2">
<xen:foreach loop="$renderedChildren" value="$child">
<div class="nodemobilesub">
<img src="styles/xfsmobile/folder_go.png" style="float: left;"><h3 class="nodeTitle">{xen:raw $child}</h3>
    
</div>
</xen:foreach>
</xen:if>
</xen:comment>
 

Russ

Well-known member
#9
It's seem you removed all hooks in PAGE_CONTAINER.
Working to add JS with page_container_js_body hook.
Well this is embarrassing isn't it :), somewhere between the transfer of dev to live, or something it wasn't showing me I had outdated templates, late night boo boo possibly ;p. Fixing now.
 

Russ

Well-known member
#13
It's asking a lot. I know it's asking a lot. But should you be willing, twitter is your friend too :whistle:
http://xenforo.com/community/resources/twitter-authentication.247/
Implemented for next version, if you care to fix it yourself, open the template "login"

Right after:
Code:
<xen:if is="!{$visitor.user_id}">

<xen:container var="$hideLoginBar">1</xen:container>
Add this:

Code:
<div style="text-align: center;">
    <xen:if hascontent="true">
        <ul id="eAuthUnit">
            <xen:contentcheck>
                <xen:hook name="login_bar_eauth_items">
                <xen:if is="{$xenOptions.facebookAppId}">
                    <xen:require css="facebook.css" />
                    <li><a href="{xen:link register/facebook, '', 'reg=1'}" class="fbLogin" tabindex="110"><span>{xen:phrase login_with_facebook}</span></a></li>
                </xen:if>
                </xen:hook>
            </xen:contentcheck>
        </ul>
    </xen:if>
</div>
It'll allow facebook/twitter auth(if enabled)
 

dihuta

Formerly Dinh Thanh
#17
Hi Russ,
I have a bug & an idea:

1. Sub forum display bug (New thread boxes are still exist)
Screen Shot 2012-02-20 at 12.18.41 PM.png

2. Idea: use mobile definition for doctype for page_container instead of using fixed 320x viewport.

<!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.2//EN" "http://www.openmobilealliance.org/tech/DTD/xhtml-mobile12.dtd">
Then remove meta tag viewport (320px), This help many browsers with different resolutions can adjust width page automatically.

Thank you.
 

Russ

Well-known member
#18
Hi Russ,
I have a bug & an idea:

1. Sub forum display bug (New thread boxes are still exist)
View attachment 25871

2. Idea: use mobile definition for doctype for page_container instead of using fixed 320x viewport.

<!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.2//EN" "http://www.openmobilealliance.org/tech/DTD/xhtml-mobile12.dtd">
Then remove meta tag viewport (320px), This help many browsers with different resolutions can adjust width page automatically.

Thank you.
Can you PM me your node tree setup for this particular section
 

yavuz

Well-known member
#19
Russ thank you for this update. Is there by chance a way to disable XenPorta when swiching to the mobile style? The portal looks really messy when the mobile style is activated...
 

Russ

Well-known member
#20
Russ thank you for this update. Is there by chance a way to disable XenPorta when swiching to the mobile style? The portal looks really messy when the mobile style is activated...
XenPorta is first on the list to make it compatible with, except it will be tricky as almost every setup is different. So... as for disabling it, I'll see what I can find out for the best method.

Not sure if you'd want to do this but you could override the default portal style in the portal options. It should still retain the mobile detect on the actual forums still.