• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
[XFA] Background Chooser

[XFA] Background Chooser [Paid] 3.1.0

No permission to buy (€7.00)

XFA

Well-known member
#1

MtoR

Well-known member
#3
At the moment, it only allows input of up to 10 images by the admin in options.
New features requests can be done through our dedicated subforum on our website.

Clément
 
#6
Nice add-on!

Our community is very diverse and it would be better if they could choose their own backgrounds. Would it be a possibility in the future in the development of this add-on to enable a feature where the user themselves can enter an image url and have that as their forum background? As opposed to having to choose between a few different default pics, that is.
 

Davyc

Well-known member
#13
Sadly this add-on doesn't work with Audentio's Corp theme. No backgrounds are shown on any page and it completely wipes out the forums leaving a blank page where categories and nodes appear.

Hopefully this can be fixed as it's potential is really good.

:unsure:
 

MtoR

Well-known member
#14
This is strange as we had added some fixes to cope with the Audentio's Corp theme.

Could you send me a test account to your forum with the add-on active please ?
 

Davyc

Well-known member
#15
@MtoR Hi thanks for responding - I'll set up a test account for you later and PM you the details. I'll have to reinstall the add-on and set it up so it may be later tonight before I can do all of this.

Thanks again and I hope you can see what's going wrong as I do like the whole idea behind this add-on.
 

MtoR

Well-known member
#17
Hi,

Once again... this is a problem with highly framework styles... They modify the templates compared to default style and the template modifications stop work.

To get it working, you have to create a template modification (didn't do it, debug mode needs to be activated), relative to the navigation template, make modification key whatever you want.

Then, in find add:
Code:
<xen:hook name="uix_navigation_right_start" />
In replace add:
Code:
$0
<xen:if is="{$visitor.permissions.general.xfa_canChooseBackground} AND {$xenOptions.xfa_bgchooser_active}">
<ul class="visitorTabs">
<li class="navTab PopupClosed">
<link href="styles/xfa/backgroundchooser/css/xfa_bgchooser.css" rel="stylesheet" />
<a href="{xen:link 'misc/background-chooser'}" class="navLink OverlayTrigger" style="font-size: 1.2em;"><i class="xfa-bgchooser-icon-picture"></i></a>
</li>
</ul>
</xen:if>
This should have it working.

Clément
 

Davyc

Well-known member
#18
Thanks for taking a look Clément, it's appreciated. I'll put this on the back burner for now as I have just had an influx of work (it does happen sometimes lol) and will get back to this and let you know how it worked out.
 

gldtn

Well-known member
#19
Hi,

Once again... this is a problem with highly framework styles... They modify the templates compared to default style and the template modifications stop work.

To get it working, you have to create a template modification (didn't do it, debug mode needs to be activated), relative to the navigation template, make modification key whatever you want.

Then, in find add:
Code:
<xen:hook name="uix_navigation_right_start" />
In replace add:
Code:
$0
<xen:if is="{$visitor.permissions.general.xfa_canChooseBackground} AND {$xenOptions.xfa_bgchooser_active}">
<ul class="visitorTabs">
<li class="navTab PopupClosed">
<link href="styles/xfa/backgroundchooser/css/xfa_bgchooser.css" rel="stylesheet" />
<a href="{xen:link 'misc/background-chooser'}" class="navLink OverlayTrigger" style="font-size: 1.2em;"><i class="xfa-bgchooser-icon-picture"></i></a>
</li>
</ul>
</xen:if>
This should have it working.

Clément
This made the background chooser appear, but it does not change background and it makes the forum listing disappear on UI.X