• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 xf_user_authenticate too high

#1
Hello.
On my forum only 1,448 registered users. Why in the table xf_user_authenticate 39000 lines. How do I clean it?

P.S. Once spammers have sent me 26,000 applications for registration. I found and removed them from the table xf_users.
 

Mike

XenForo developer
Staff member
#2
P.S. Once spammers have sent me 26,000 applications for registration. I found and removed them from the table xf_users.
You answered your own question there. You manually manipulated the database which is a really bad idea...

You will need to remove records from a number of additional tables by hand. Alternatively (and preferably), restore to a backup before you removed the data and remove the users via the control panel.
 
#3
I just wonder why in this table are extra lines?

I cleared 26,000 lines - it's spammers. I have 1,448. 11552 remains, who are these people?
 

Jeremy

Well-known member
#4
You said it in your first post:

You removed data from xf_user manually from the table. This leaves other records in tact, such as xf_user_authenticate. As Mike said, you'll either need to restore from a backup and use the proper XenForo tools (that'll remove all necessary data) or go through several tables and remove the necessary information as well.
 
#5
I think you do not understand me, because I use the Google translator. I had 11552 extra lines in the table xf_user_authenticate even before I cleared the table xf_users.

Imagine, I did not clean the table at all. I have 26,000 applications for registration confirmation. 1448 users. and 11552 extra lines in the table xf_user_authenticate.

What do you say now?

I think these lines are created if enabled confirmation of registration. And it is not removed then. I think this is a bug.
 
Last edited:

Mike

XenForo developer
Staff member
#6
Users deleted through XenForo will have their records removed from this table and many others. If you have extra records in this table, you would need to remove them manually.