1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 xf_search_index keeps crashing HELP!

Discussion in 'Troubleshooting and Problems' started by hterrag, Aug 1, 2014.

  1. hterrag

    hterrag Active Member

    Recently I keep getting this server error as below when creating a thread or posting, etc. This is happening frequently too. I fix it by rebuilding the search index but it keeps recurring after some time.

    I also tried to repair my DB in cpanel but it says for all the tables:
    "The storage engine for the table doesn't support repair"

    Any ideas why this keeps happening? How can I permanently fix this? Help!

    Server Error:
    Code:
    xf_search_index' is marked as crashed and should be repaired - library/Zend/Db/Statement/Mysqli.php:77
     
    Last edited: Aug 1, 2014
  2. Brogan

    Brogan XenForo Moderator Staff Member

    If it is crashing frequently, then it could be a sign of an unstable server, MySQL being stopped incorrectly, etc.

    Contact your host and ask them to check the server error logs and status.
     
  3. MattW

    MattW Well-Known Member

    xf_search_index should be MyISAM and should support repair

    What is the current storage engine for that table in your DB?
     
    SneakyDave likes this.
  4. hterrag

    hterrag Active Member

    OKay just contacted my host and will update back here on their reply. Thanks!
     
  5. hterrag

    hterrag Active Member

    I'm on shared hosting so I'm not sure.
     
  6. MattW

    MattW Well-Known Member

    You should be able to see it via phpMyAdmin
    upload_2014-8-1_17-21-49.png
     
    hterrag and SneakyDave like this.
  7. hterrag

    hterrag Active Member

    Thanks and yup it is MyISAM.
     

Share This Page