• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug XF 1.1.1 / Notices on Forum-node are not scrolling in Android

erich37

Well-known member
#1
when accessing my forum via my Android-phone browser, the "Notices" at Forum-nodes are not scrolling.
However the "Notices" are scrolling fine at the "Homepage" when looking at them via my Android-phone.

When looking at the "Notices" via FireFox on my computer, everything is scrolling fine.

I have tested this now extensively and it seems this is related to:
- "Display Order", as when changing the "Display Order" back and forth, it appears correctly even in Android-browser.
- It could also be that Notices which have activated "user is a guest" are showing before other Notices which do not have this option activated, thereby ignoring the set "Display Order".

The issue happens when:
Notice1:
"Notice" at which "Privileges and Status:" is set to "user is a guest".
this Notice has a Display Order of 60

Notice2:
"Notice" having "Privileges and Status:" not set (visible for every user).
this Notice has a Display Order of 50.

when exchanging the "Display Order" of those 2 Notices (as per example above), then the issue is not showing up. Saying if you give the "Notice1" a Display-order of 50 and the "Notice2" a Display-order of 60, then the issue is not showing up.
 

Mike

XenForo developer
Staff member
#3
Works fine here on my Android phone (Galaxy S II). There really shouldn't be any difference between the home and node pages. The only thing I can think of is that you tapped and focused on the notice area, as that will stop the scrolling (intentionally).
 

erich37

Well-known member
#4
Works fine here on my Android phone (Galaxy S II). There really shouldn't be any difference between the home and node pages. The only thing I can think of is that you tapped and focused on the notice area, as that will stop the scrolling (intentionally).
no, that is not the issue.

I would guess if you have the same "Sort Order number" for different Notices, then it gives those issues when browsing via Android.
Sorry, I could not make a screenshot on my mobile-phone... but it was definitely looking weird and buggy.