[XenMax] - Hide Link With Guests

[XenMax] - Hide Link With Guests 2017-12-16

No permission to download

Paul R

Active member
Paul R submitted a new resource:

[XenMax] - Hide Link With Guests - [XenMax] - Hide Link With Guests => hide your link to your visitors.

Description:
Hide link with guests with more feature

View attachment 163299

View attachment 163300


View attachment 163301

Installation:
  1. Download XenMax-HidelinkGuests-2.0.0.zip and unzip it.
  2. Upload the src directory to your server.
  3. From the Admin Control Panel Install the add-on.
Note:
Vote 5 star if you like this addon

Read more about this resource...
 

khan786

Active member
Beautiful addon just installed works and looks fine. Great thing about this addon has no messy copy right links.
Awesome job!
 

TC44

Member
Hi there,

After disabling the addon it's still restricting links to unregistered guests. Same after uninstalling. Any suggestions?
 

khan786

Active member
First day I installed worked fine and guests could not see my YouTube links, but now after updating still it is showing links to guests :(
 

Paul R

Active member
First day I installed worked fine and guests could not see my YouTube links, but now after updating still it is showing links to guests :(
Hi there,

After disabling the addon it's still restricting links to unregistered guests. Same after uninstalling. Any suggestions?
please config whitelist domain in admincp
 
Last edited:

haqzore

Active member
what is Whitelist and what it does? I am confused :(
Admin Control Panel > Addons > Hide Links With Guests > Options

"Whitelist" is another word for "allowed". Put another way - any domain on the whitelist would be shown, and NOT hidden by this mod.

Like I said before, having to use the "Whitelist" when the add-on is disabled makes no sense, and is not a fix. If the add-on is disabled/uninstalled, no links should be hidden anyways.
 

Paul R

Active member
Admin Control Panel > Addons > Hide Links With Guests > Options

"Whitelist" is another word for "allowed". Put another way - any domain on the whitelist would be shown, and NOT hidden by this mod.

Like I said before, having to use the "Whitelist" when the add-on is disabled makes no sense, and is not a fix. If the add-on is disabled/uninstalled, no links should be hidden anyways.
yes. disabled/uninstalled = not work => it is real ^^
 

mkucuksari

Well-known member
Many thanks @Paul R . It is really a great addon.

I will ask you if you can add one more feature. It will be great if we can also hide MEDIAS links like youtube, facebook.. .videos from guest.
 

CNK

Active member
I have problem with white list - changes don't save, I can't add anything to the whitelist

Edit:

ok, it should be full url with https:// not only domain.
 
Last edited:
  • Like
Reactions: Qeq

Eagle

Well-known member
I get the following error:

Code:
ErrorException: Template error: parse_url() expects parameter 1 to be string, array given src/addons/XenMax/HideLinkGuests/Repository/CheckLinks.php:30
Generated by: Admin Jan 13, 2019 at 3:34 PM

Code:
#0 [internal function]: XF\Template\Templater->handleTemplateError(2, 'parse_url() exp...', '/home/dom...', 30, Array)
#1 src/addons/XenMax/HideLinkGuests/Repository/CheckLinks.php(30): parse_url(Array)
#2 src/addons/XenMax/HideLinkGuests/XF/BbCode/Renderer/Html.php(35): XenMax\HideLinkGuests\Repository\CheckLinks->checkUrl(Array)
#3 [internal function]: XenMax\HideLinkGuests\XF\BbCode\Renderer\Html->renderTagUrl(Array, Array, Array, Array, Object(XenMax\HideLinkGuests\XF\BbCode\Renderer\Html))
#4 src/XF/BbCode/Renderer/Html.php(284): call_user_func(Array, Array, Array, Array, Array, Object(XenMax\HideLinkGuests\XF\BbCode\Renderer\Html))
#5 src/XF/BbCode/Traverser.php(61): XF\BbCode\Renderer\Html->renderTag(Array, Array)
#6 src/XF/BbCode/Traverser.php(37): XF\BbCode\Traverser->renderSubTree(Array, Array)
#7 src/XF/BbCode/Traverser.php(20): XF\BbCode\Traverser->renderAst(Array, Object(XF\BbCode\RuleSet), Array)
#8 src/XF/SubContainer/BbCode.php(219): XF\BbCode\Traverser->render('[B]Testing thread...', Object(XF\BbCode\Parser), Object(XF\BbCode\RuleSet), Array)
#9 src/XF/Template/Templater.php(2009): XF\SubContainer\BbCode->render('[B]Testing thread...', 'html', 'post', Object(XFMG\XF\Entity\Post), Array)
#10 [internal function]: XF\Template\Templater->fnBbCode(Object(BR\ModernStatistic\XF\Template\Templater), false, '[B]testing...', 'post', Object(XFMG\XF\Entity\Post))
#11 src/XF/Template/Templater.php(914): call_user_func_array(Array, Array)
#12 internal_data/code_cache/templates/l2/s1/public/post_macros.php(154): XF\Template\Templater->fn('bb_code', Array, false)
#13 src/XF/Template/Templater.php(693): XF\Template\Templater->{closure}(Object(BR\ModernStatistic\XF\Template\Templater), Array, Array)
#14 internal_data/code_cache/templates/l2/s1/public/thread_view.php(528): XF\Template\Templater->callMacro('post_macros', 'post', Array, Array)
#15 src/XF/Template/Templater.php(1293): XF\Template\Templater->{closure}(Object(BR\ModernStatistic\XF\Template\Templater), Array)
#16 src/addons/BR/ModernStatistic/XF/Template/Templater.php(27): XF\Template\Templater->renderTemplate('thread_view', Array, true)
#17 src/XF/Template/Template.php(24): BR\ModernStatistic\XF\Template\Templater->renderTemplate('public:thread_v...', Array)
#18 src/XF/Mvc/Renderer/Html.php(48): XF\Template\Template->render()
#19 src/XF/Mvc/Dispatcher.php(418): XF\Mvc\Renderer\Html->renderView('XF:Thread\\View', 'public:thread_v...', Array)
#20 src/XF/Mvc/Dispatcher.php(400): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#21 src/XF/Mvc/Dispatcher.php(360): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#22 src/XF/Mvc/Dispatcher.php(53): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#23 src/XF/App.php(2170): XF\Mvc\Dispatcher->run()
#24 src/XF.php(392): XF\App->run()
#25 index.php(20): XF::runApp('XF\\Pub\\App')
#26 {main}

It seems like the Unfurl that caused the problems.
 

Ozzy47

Well-known member
I get the following error:

Code:
ErrorException: Template error: parse_url() expects parameter 1 to be string, array given src/addons/XenMax/HideLinkGuests/Repository/CheckLinks.php:30
Generated by: Admin Jan 13, 2019 at 3:34 PM

Code:
#0 [internal function]: XF\Template\Templater->handleTemplateError(2, 'parse_url() exp...', '/home/dom...', 30, Array)
#1 src/addons/XenMax/HideLinkGuests/Repository/CheckLinks.php(30): parse_url(Array)
#2 src/addons/XenMax/HideLinkGuests/XF/BbCode/Renderer/Html.php(35): XenMax\HideLinkGuests\Repository\CheckLinks->checkUrl(Array)
#3 [internal function]: XenMax\HideLinkGuests\XF\BbCode\Renderer\Html->renderTagUrl(Array, Array, Array, Array, Object(XenMax\HideLinkGuests\XF\BbCode\Renderer\Html))
#4 src/XF/BbCode/Renderer/Html.php(284): call_user_func(Array, Array, Array, Array, Array, Object(XenMax\HideLinkGuests\XF\BbCode\Renderer\Html))
#5 src/XF/BbCode/Traverser.php(61): XF\BbCode\Renderer\Html->renderTag(Array, Array)
#6 src/XF/BbCode/Traverser.php(37): XF\BbCode\Traverser->renderSubTree(Array, Array)
#7 src/XF/BbCode/Traverser.php(20): XF\BbCode\Traverser->renderAst(Array, Object(XF\BbCode\RuleSet), Array)
#8 src/XF/SubContainer/BbCode.php(219): XF\BbCode\Traverser->render('[B]Testing thread...', Object(XF\BbCode\Parser), Object(XF\BbCode\RuleSet), Array)
#9 src/XF/Template/Templater.php(2009): XF\SubContainer\BbCode->render('[B]Testing thread...', 'html', 'post', Object(XFMG\XF\Entity\Post), Array)
#10 [internal function]: XF\Template\Templater->fnBbCode(Object(BR\ModernStatistic\XF\Template\Templater), false, '[B]testing...', 'post', Object(XFMG\XF\Entity\Post))
#11 src/XF/Template/Templater.php(914): call_user_func_array(Array, Array)
#12 internal_data/code_cache/templates/l2/s1/public/post_macros.php(154): XF\Template\Templater->fn('bb_code', Array, false)
#13 src/XF/Template/Templater.php(693): XF\Template\Templater->{closure}(Object(BR\ModernStatistic\XF\Template\Templater), Array, Array)
#14 internal_data/code_cache/templates/l2/s1/public/thread_view.php(528): XF\Template\Templater->callMacro('post_macros', 'post', Array, Array)
#15 src/XF/Template/Templater.php(1293): XF\Template\Templater->{closure}(Object(BR\ModernStatistic\XF\Template\Templater), Array)
#16 src/addons/BR/ModernStatistic/XF/Template/Templater.php(27): XF\Template\Templater->renderTemplate('thread_view', Array, true)
#17 src/XF/Template/Template.php(24): BR\ModernStatistic\XF\Template\Templater->renderTemplate('public:thread_v...', Array)
#18 src/XF/Mvc/Renderer/Html.php(48): XF\Template\Template->render()
#19 src/XF/Mvc/Dispatcher.php(418): XF\Mvc\Renderer\Html->renderView('XF:Thread\\View', 'public:thread_v...', Array)
#20 src/XF/Mvc/Dispatcher.php(400): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#21 src/XF/Mvc/Dispatcher.php(360): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#22 src/XF/Mvc/Dispatcher.php(53): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#23 src/XF/App.php(2170): XF\Mvc\Dispatcher->run()
#24 src/XF.php(392): XF\App->run()
#25 index.php(20): XF::runApp('XF\\Pub\\App')
#26 {main}

It seems like the Unfurl that caused the problems.

You are better off ditching this addon, the author abandoned the community and has taken !only from people and not delivered work.
 
Top