• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 xenforo.full JS Files?

Brogan

XenForo moderator
Staff member
#2
You can download the latest 1.2.5 .zip and upload the full js file from there.

The 1.2.5 package has been updated with the new file.
 

Divvens

Well-known member
#4
To be precise, /js/xenforo.full/ <- I have this folder where I overwrote a file (where all files were last edited back in 2011).
 

Mike

XenForo developer
Staff member
#7
If it's no longer in the download, it's not needed. (I believe that may have been the original approach in 1.0, I think.)
 

Divvens

Well-known member
#9
If it's no longer in the download, it's not needed. (I believe that may have been the original approach in 1.0, I think.)
Thank you for clarifying the issue! I was under the impression that I overwrote something that wasn't supposed to be overwritten.
 

Divvens

Well-known member
#10
@Mike @Brogan I just downloaded the 1.0 package (upgrade & complete) and surprisingly js/xenforo.full isn't even a package on there, I can only see js/xenforo, 1.1 onwards there is a js/xenforo/full.

Was the file removed at any process in the XenForo development, or I have a folder which shouldn't have been there at all on my server somehow?
 

Divvens

Well-known member
#14
I have just checked 1.0.0 B1 and it's not there.

I suspect you created it yourself.
I spotted xenforo.full in the following versions:
1.1 Beta 1
1.1 Beta 2
1.1 Beta 3


The folder doesn't continue anymore from 1.1 Beta 4 onwards. I haven't created any folders within the js as far as I can remember :) I was just investigating the files and came across these on the beta releases. Can I delete the folder from my live installation or will it cause any problem?
xenforodotfull.png
 

Brogan

XenForo moderator
Staff member
#15
Ah yes, it looks like it appeared in 1.1 Beta and then disappeared before the stable release.

You can safely remove it.
 

Divvens

Well-known member
#16
Ah yes, it looks like it appeared in 1.1 Beta and then disappeared before the stable release.

You can safely remove it.
I've removed that folder.

The file health check states:
js/xenforo/full/lightbox.js
File does not contain expected contents.

js/xenforo/lightbox.js
File does not contain expected contents.

Is it normal because I just applied the patch rather than having uploaded all of the upload package?