XenForo 2.1.9 and 2.0.13 Released (Security Fix)

Today, we are releasing XenForo 2.1.9 and XenForo 2.0.13 to address a potential security vulnerability that may affect any customer who makes use of our PayPal payment handler.

As well as user upgrades, this may affect add-ons you have installed which process payments using our PayPal payment handler.

We recommend that all affected customers running XenForo 2.1 or XenForo 2.0 upgrade to 2.1.9 or 2.0.13 or use one of the attached patch files as soon as possible.

Specifically, the issue relates to a specially crafted callback (or IPN) which is then processed successfully using PayPal's sandbox validation endpoint instead of their live system. If successful, a purchase could be completed without your PayPal account actually receiving any funds.

There are no other fixes included in this version. There will be a further 2.1 maintenance release in the coming weeks.

Applying a Fix: Upgrading
You may upgrade to 2.1.9 or 2.0.13 to fix this issue. You should upgrade as you would to any other release.

Customers with an active license may download 2.1.9 or 2.0.13 from their customer area. Full details for how to install and upgrade XenForo can be found in the XenForo Manual.

If you are running XF 2.1 you can upgrade directly from within your control panel.

Applying a Fix: Patching
Alternatively, this issue can be fixed by applying the patch in the attached file. You should simply overwrite the following file with the version attached to this message:
  • src/XF/Payment/PayPal.php
The file can be found at the same path within the attachment.

Please ensure you download the correct patch for your XenForo version. If you are running XenForo 2.1.5 or above then please only download xf-patch-219.zip. If you are running XenForo 2.0 then please only download xf-patch-2013.zip.
 

Attachments

  • xf-patch-219.zip
    4.4 KB · Views: 423
  • xf-patch-2013.zip
    4.3 KB · Views: 121

Chris D

XenForo developer
Staff member
Applying a Fix: Patching versions prior to XenForo 2.1.5

It has been brought to our attention that customers who are using XenForo 2.1 prior to XenForo 2.1.5 may experience server errors due to older versions of XenForo 2.1 not containing a method used by newer versions.

Therefore if you are using XenForo 2.1.0 - 2.1.4 you should use the attached xf-patch-214.zip rather than the xf-patch-219.zip patch mentioned in the first post.
 

Attachments

  • xf-patch-214.zip
    4.3 KB · Views: 71
Top