[XenConcept] Linked Accounts

[XenConcept] Linked Accounts [Paid] 2.1.0

No permission to buy ($40.00)

siONtI

Well-known member
Also if you login into a linked account which is in a usergroup that does not have "Can use linked account system" permission you cannot switch back to main account (you need to logout and then login again).


Edit: I'm getting those errors on control panel

Server error log

Code:
TypeError: Argument 2 passed to XenConcept\LinkedAccount\XF\Repository\ThreadWatch::deleteAutoWatchForLinkedAccount() must be an instance of XF\Entity\User, null given, called in /share/www/forum1/public_html/src/addons/XenConcept/LinkedAccount/XF/Pub/Controller/Thread.php on line 45 src/addons/XenConcept/LinkedAccount/XF/Repository/ThreadWatch.php:16
Generated by: user1 Jun 16, 2019 at 5:53 PM

Stack trace
#0 src/addons/XenConcept/LinkedAccount/XF/Pub/Controller/Thread.php(45): XenConcept\LinkedAccount\XF\Repository\ThreadWatch->deleteAutoWatchForLinkedAccount(Object(SV\ElasticSearchEssentials\XF\Entity\Thread), NULL)
#1 src/addons/SV/UserEssentials/XF/Pub/Controller/Thread.php(52): XenConcept\LinkedAccount\XF\Pub\Controller\Thread->finalizeThreadReply(Object(XenConcept\LinkedAccount\XF\Service\Thread\Replier))
#2 src/XF/Pub/Controller/Thread.php(463): SV\UserEssentials\XF\Pub\Controller\Thread->finalizeThreadReply(Object(XenConcept\LinkedAccount\XF\Service\Thread\Replier))
#3 src/XF/Mvc/Dispatcher.php(321): XF\Pub\Controller\Thread->actionAddReply(Object(XF\Mvc\ParameterBag))
#4 src/XF/Mvc/Dispatcher.php(248): XF\Mvc\Dispatcher->dispatchClass('XF:Thread', 'AddReply', Object(XF\Mvc\RouteMatch), Object(SV\ElasticSearchEssentials\XF\Pub\Controller\Thread), NULL)
#5 src/XF/Mvc/Dispatcher.php(100): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(SV\ElasticSearchEssentials\XF\Pub\Controller\Thread), NULL)
#6 src/XF/Mvc/Dispatcher.php(50): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#7 src/XF/App.php(2177): XF\Mvc\Dispatcher->run()
#8 src/XF.php(390): XF\App->run()
#9 index.php(20): XF::runApp('XF\\Pub\\App')
#10 {main}
Code:
Request state
array(4) {
["url"] => string(77) "/threads/randomthreadname.30576/add-reply"
["referrer"] => bool(false)
["_GET"] => array(1) {
["/threads/randomthreadname_30576/add-reply"] => string(0) ""
}
["_POST"] => array(9) {
["message_html"] => string(135) "<p>[QUOTE="User1, post: 2034219, member: 492383"]</p><p>randomtext</p><p>[/QUOTE]</p><p>randomtext</p>"
["attachment_hash"] => string(32) "86576b621e44d456be41adc881558a9d"
["attachment_hash_combined"] => string(87) "{"type":"post","context":{"thread_id":30576},"hash":"86576b621e44d456be41adc881558a9d"}"
["last_date"] => string(10) "1560707601"
["last_known_date"] => string(10) "1560707532"
["_xfToken"] => string(8) "********"
["_xfRequestUri"] => string(76) "/threads/randomthreadname.30576/page-107"
["_xfWithData"] => string(1) "1"
["_xfResponseType"] => string(4) "json"
}
}
 
Last edited:

XenConcept

Well-known member
Can you make it compatible with UI.X theme?

The menu is well displayed. The icon used and "font awesome" except that UIX uses icon material.

Add this to the extra.less template

Code:
.p-navgroup-link--linked i:after
{
    <xf:macro template="uix_icons.less" name="content" arg-icon="link" />
}
 

Epi

Active member
@XenConcept
One bug I encountered in latest version, the linked accounts don't show up in the linked account page.

PHP:
LogicException: Macro public:xc_linked_account_member_list_macros :: item() error: Macro argument buttonPhrase is required and no value was provided src/XF/Template/Templater.php:809

PHP:
#0 internal_data/code_cache/templates/l1/s23/public/xc_linked_account_member_list_macros.php(14): XF\Template\Templater->mergeMacroArguments(Array, Array, Array)
#1 src/XF/Template/Templater.php(701): XF\Template\Templater->{closure}(Object(XenMake\StyleProperty\XF\Template\Templater), Array, Array)
#2 internal_data/code_cache/templates/l1/s23/public/xc_linked_account_account_linked_account.php(45): XF\Template\Templater->callMacro('xc_linked_accou...', 'item', Array, Array)
#3 src/XF/Template/Templater.php(1301): XF\Template\Templater->{closure}(Object(XenMake\StyleProperty\XF\Template\Templater), Array)
#4 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('xc_linked_accou...', Array)
#5 src/XF/Mvc/Renderer/Html.php(48): XF\Template\Template->render()
#6 src/XF/Mvc/Dispatcher.php(418): XF\Mvc\Renderer\Html->renderView('XF:Account\\Link...', 'public:xc_linke...', Array)
#7 src/XF/Mvc/Dispatcher.php(400): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#8 src/XF/Mvc/Dispatcher.php(360): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#9 src/XF/Mvc/Dispatcher.php(53): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#10 src/XF/App.php(2177): XF\Mvc\Dispatcher->run()
#11 src/XF.php(390): XF\App->run()
#12 index.php(20): XF::runApp('XF\\Pub\\App')
#13 {main}

PHP:
array(4) {
  ["url"] => string(23) "/account/linked-account"
  ["referrer"] => string(42) "https:/localhost/xen/account/linked-account"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

siONtI

Well-known member
@XenConcept
One bug I encountered in latest version, the linked accounts don't show up in the linked account page.
Yep same issue.

Another bug: Threads on watch list are removed (unwatched) after commenting. (No error logs on control panel)

How to reproduce it:
1. Create a new thread (or watch a existing thread)
2. Add it on watch list
3. Reply on that thread

Thread is removed from watch list.
 
  • Like
Reactions: Epi

XenConcept

Well-known member

seebs

Member
So, I have an existing XF1.5 forum which has a lot of users relying heavily on an older "subaccounts" feature, which it sounds like this nearly replaces.

How easy or hard would it be to migrate in data from such a thing into this new thing?
 

XenConcept

Well-known member
So, I have an existing XF1.5 forum which has a lot of users relying heavily on an older "subaccounts" feature, which it sounds like this nearly replaces.

How easy or hard would it be to migrate in data from such a thing into this new thing?

I would need the add-on in order to create an importer.
 

Sperber

Well-known member
Remi,
this is a really interesting add-on and I´m wondering, why I haven´t seen it before. Bought a license the other day now. Really nice idea, but may I suggest - like others did before - to add an option where a linked account (which hasn´t the same privileges as the main account) still has an account switcher? In most situations I can think of, the linked account will be used as an account with less privileges as the parent one. In our use case we have several paid user groups, but the linked account is only for company profiles to post their job offers with their real company names, instead a personal user account. Those company profiles are basic and free accounts and only allowed to post in certain nodes. For those it´s very uncomfortable and unattractive to be forced to log out each time they have entered the linked account and can´t switch back.

Any chance you could add that account switcher, even for user groups without explicit privileges for "Linked accounts"?
 
Last edited:

siONtI

Well-known member
When i try to switch (revert) back to my main account it get:
Page not found
The requested page could not be found.

Also i think "unlink account" option should be only on "Manage your linked accounts" page. Before it was ok just one button (Login/revert) now you need to click on the settings icon & click login ._.

Capture.PNG
 

XenConcept

Well-known member
Hello,

When i try to switch (revert) back to my main account it get:
Page not found
The requested page could not be found.

Can you elaborate? I don't have any problems moving from a secondary account to the main account.

Also i think "unlink account" option should be only on "Manage your linked accounts" page. Before it was ok just one button (Login/revert) now you need to click on the settings icon & click login ._.

There may be other buttons later on.
 
Top