• This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

Xen-TR Forum Moderators

DrYontem

Well-known member
Install and Upgrade Instructions
1-) Upload the necessary files/folders in _upload folder
2-) Install addon_xentr_com_forum_mods_v1.1.0.xml via add-on installer
3-) open forum_view template and add this code its end
HTML:
<xen:include template="xen_tr_com_forum_mods" />

Version History
  • v.1.0.0 --> 17 Jan 2011 --> First Release
  • v.1.1.0 --> 3 May 2011 --> fixed parent mod bug, fixed empty div bug
 

Attachments

  • forum_mods.jpg
    forum_mods.jpg
    134.1 KB · Views: 98
  • Xen-TR_Forum_Moderators_v1.1.0.zip
    4.5 KB · Views: 28
R

ragtek

Guest
Nice one and very useful, BUT
1. You should use XenForo_Model::create('XenForo_Model_User'); instead of $userModel = new Xenforo_Model_User;
2. I don't see any sense, extending your model from the xenforo_model_user...

2. Because the mods aren't changed daily, you could cache them, instead of sending the query on every forum page load.
 

DrYontem

Well-known member
Nice one and very useful, BUT
1. You should use XenForo_Model::create('XenForo_Model_User'); instead of $userModel = new Xenforo_Model_User;
2. I don't see any sense, extending your model from the xenforo_model_user...

2. Because the mods aren't changed daily, you could cache them, instead of sending the query on every forum page load.

thanks for your advice, i will pay attention for these subjects on future versions and add-ons
thanks again :thumbup:
 
Very nice addon!

I have installed it on 1.0.0 stable version and works great but I suggest, if possible, the hide of block when there are not mods in a forum.

Thanks again for your work!
 

Romchik®

Well-known member
Tilkißey
There is forums without moderators. It would be better in such forums not show empty panel.
 

htdesignz

Active member
I installed this addon on my forum, and check the log when I always see the error:

Undefined variable: XenTrCom_ForumModerators
library/XenTrCom/ForumModerators/Controller/Public.php:13

How do I fix this?
 
Top