1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wrap xenforo in a template + other changes

Discussion in 'Styling and Customization Questions' started by dojo, Feb 7, 2012.

  1. dojo

    dojo Active Member

    I would like to apologize if I'm captain obvious and am asking 'useless' questions, I'm very new to XenForo and still can't find my way around it. I have read the manual, but my questions weren't answered and what changes I make don't work.

    Here is the first thing I need to do on my new board www.top-community.com

    I want to create another menu that comes ABOVE the logo area. I have tried to put it in the HEADER template, but it doesn't work. The content appears in the footer, above the grey menu with the rss link and all the jazz. So somewhere I'm messing it up.

    Then I want to add in the footer, under the main forum, a high area where to list links and other stuff like this. Both these elements need to appear sidewide.

    From what I read there should be a template that controls the entire layout, the problem is that I didn't find it.

    Any help is much appreciated. I have successfully customized most forum scripts (vbulletin, mybb, phpBB), but can't really get a head start in this. I have changed some colors, but I want to do more :)
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. dojo

    dojo Active Member

    Thank you for the fast response. Will try use this and then 'buzz' you again with other questions for sure ;)
     
  4. dojo

    dojo Active Member

    It seems to have worked nicely. I was able to 'wrap' the forum closer to what I wanted. One thing I noticed though: if I edit the HTML or CSS on a template, the NAVIGATION colors 'revert' to something that was used before. It shows my new changes OK for a while and then, without me 'asking' for a revert, the navigation style changes to something that was previously. I had to work 2 times already to have the blue nav. Noticed this days ago when I started customizing. The moment I touched a template, the navigation went back to the older settings.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You can have multiple templates open in different tabs in the template editor. Maybe you had an older version of navigation opened in another tab which got saved while editing a different template. I have had this happen to me.
     
    Brett Peters likes this.
  6. dojo

    dojo Active Member

    I do tend to work with 10+tabs open. Maybe this is what went wrong. Thank you guys for the amazing support.
     
  7. Brett Peters

    Brett Peters Well-Known Member

    I have learnt that lesson more than once :ROFLMAO:
     

Share This Page