• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Why one forum loads MUCH slower than others...

craigiri

Well-known member
#1
There is nothing different about this forum - it is not the busiest nor the biggest, but the stats show it loads incredibly slowly!
Screen shot 2012-11-30 at 1.29.45 PM.png
Note that the Pellet forum is taking vastly longer to load - 5X as long in many cases!

Google seems to show that it is not at the server end, but at the Document Content Loaded end as below.
Screen shot 2012-11-30 at 1.32.06 PM.png

This is really perplexing me.......because there is nothing different about that forum!

Any guesses?
 

CTXMedia

Formerly CyclingTribe
#3
What / where is "ib.adnx.com" loading / from?

Physically the page loads and displays very quickly for me - doesn't seem slow at all on my screen - however if Google's bot is counting until the very last morsel of the page content has downloaded then ib.adnx.com may be a bottleneck item that is skewing the figures. After giving it a few tries, there are others too ... tca-52.tca-rtb1.rfihub.net - b.search.somthingorother etc.

Possibly related to your ads? Try loading your forum pages in Firefox and watch in the bottom left corner as it reports what it is loading - it carries on long after the main page content has been display. (y)

Cheers,
Shaun :D
 

craigiri

Well-known member
#4
Any of those ads are google ads.....

my own ads load from my own server......quickly.

Oh, I get it - so it may be quick for the user, but then goog calls it slower because of the later loading piece. That makes some sense....

Thanks....

The adnx domain seems to be some kind of 3rd party cookie tracker - and some sites, including google, say it has infected computers and spread malware!
http://google.com/safebrowsing/diagnostic?site=adnxs.com

BUT, my guess is that it's the google ads which are bringing it in! Weird......
 

x3sphere

Active member
#5
Google page speed does count advertisements, in general our pages load in around 2-3 sec for most users but with ads it jumps to around 7-8 seconds.
 

craigiri

Well-known member
#6
The strange thing here is that nothing is different in that forum than in the others - so any such issue should be showing up in other forums pages speeds as well.....

Well, I'm not going to sweat too much - just keeping an eye on it and I did block a couple domains from my adsense CP.
 

CTXMedia

Formerly CyclingTribe
#7
Okay, give this a try ... visit CycleChat (as a guest - who is exposed to ads): http://www.cyclechat.net/ - browse around and get an idea of how quickly/slowly the pages load, get a figure in your mind about how many seconds you feel it takes each page, then look at these results and see if you are surprised!! :eek: : http://www.webpagetest.org/result/121130_PY_GNG/

Then have a look at these figures for your homepage: http://www.webpagetest.org/result/121130_C4_HQ6/

And then look at these results (and look at the waterfall breakdown) for your "slow" forum: http://www.webpagetest.org/result/121130_PB_HQK/

Hopefully all of that lot will put your mind at rest. (y)

Cheers,
Shaun :D