1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 White pages and database errors when upgrading and installing addons

Discussion in 'Troubleshooting and Problems' started by racersimage, Aug 15, 2015.

  1. racersimage

    racersimage Active Member

    I'm noticing more and more often that when I start to install an addon, doesn't matter which one, most recent issue was the Xenforo Media Gallery 1.1.0 RC1 that after starting the upgrade, I'll eventually get a white page and numerous database errors. My site is acting like it's failing to install or update addons that make changes to database tables. I have to try numerous times to get this addons to upgrade/install addons.

    Could it be a problem with MySQL or a timeout issue?

    MySQL Version is 5.5.45-MariaDB
  2. racersimage

    racersimage Active Member

    I'll get directed to a white page while trying to uninstall addons too and they'll appear to be uninstalled but the templates and database tables will still be there.
  3. Slavik

    Slavik XenForo Moderator Staff Member

    Is this on a default install?

    Regardless, it sounds as if you may have some serious hosting issues, you're first port of call should be the host to check logs for what is happening.
  4. racersimage

    racersimage Active Member

    No, I do have quite a few addons installed. I opened a support ticket this morning with my host (Wiredtree) and they didn't really help me out all that much. They upgraded my cPanel to the latest version but never could pinpoint any of my issues.
  5. Mike

    Mike XenForo Developer Staff Member

    What specifically do you see before the white page? What sort of database errors are you referring to?
  6. racersimage

    racersimage Active Member

    Usually the database errors refer to the addons that haven't been fully installed. Specifically with the Xenforo Media Gallery, I'd start the upgrade, my browser would start the loading process, nothing would happen (such as reparsing/rebuilding) and then I'd get a white page, the page would go blank. The addon wouldn't be upgraded yet database tables would be altered. It's like with any addon recently that alters tables, I have trouble installing it.

Share This Page