1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Which Style Property ?

Discussion in 'Styling and Customization Questions' started by tafreehm, May 17, 2012.

  1. tafreehm

    tafreehm Well-Known Member

    Hello,
    I am looking for few style properties to make changes.

    1. Font color for top navigation text (for example: HOME FORUM BUY XENFORO etc)
    2. Background Color and Size for Sub Navigation (Mark Forum Read, Search Forums etc)
    3. Avatar Size control at Sidebar and in userinfo at message also at profile page.
    I could not find any style properties for above. I will post more if I need help.

    Thanks
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  3. tafreehm

    tafreehm Well-Known Member

    HeyJake, Thanks for that. second link you posted did not work for me.
    Also for this
    How can I have custom size ? L is sort of too big for what I m looking for.

    -----------
    I did create a custom property, but it does not seems to be working:
    HTML:
    .avatar .img.c { width: 150px; height: 165px; }
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    To have a custom avatar size other than s, m, or l requires modifying the code like this:

    http://xenforo.com/community/threads/how-do-i-change-avatar-size.6817/#post-109103

    That changes the size of the "m" avatar which is used in posts. In addition you will need to adjust the size of the author area in posts to accommodate the new size:

    Admin CP -> Appearance -> Style Properties -> Message Layout
    > User Info Container
    > Content Container


    One controls the box itself, the other controls the space allocated for the box.
     
    mistypants likes this.
  5. tafreehm

    tafreehm Well-Known Member

    so S, M and L only been used in Message area ? If I modify m's properties its only gonna take affect in one location only. Right?
    and the link you posted in above post, gives me permission error.
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Oh I'm sorry. It's a deleted thread. I didn't notice because I'm a mod. Here is a quote:

    And this change will affect all "m" avatars, not just those in posts.
     
  7. tafreehm

    tafreehm Well-Known Member

    Thanks Jake.. Now How I can move Search Bar position ? I could not find any style property for search bar ?
    I haven't look into any templates yet..
     
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Admin CP -> Appearance -> Templates -> EXTRA.css

    Add this code:

    Code:
    #QuickSearch
    {
    	position: absolute;
    	right: 20px;
    	top: -18px;
    }
    
    Those are the default position adjustments. You can change them.
     
    Lindal_Oronar and Cal like this.
  9. DRE

    DRE Well-Known Member

    Can I add those css edits in Extra.css or do I absolutely have to edit the xenforo.css and navigation.css templates?
     
  10. Jeremy P

    Jeremy P Well-Known Member

    You should never have to. Try it in EXTRA.css and if it doesn't work, add !important before the ; on each CSS property.
     
    8thos and Jake Bunce like this.
  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You can copy it to EXTRA.css
     
  12. DRE

    DRE Well-Known Member

    I did already thanks ya'll!
     
  13. psTubble27

    psTubble27 Well-Known Member

    Hi @Jake Bunce, quick question.

    Here's a sample test-case avatar.

    If I set the avatar size to medium:
    Code:
    <xen:avatar user="$user" size="m" img="true" />
    The result looks as it's supposed to:
    postbit-m.png
    (The bottom part of the image is cropped.)

    However if I set the avatar to large:
    Code:
    <xen:avatar user="$user" size="l" img="true" />
    The system inserts an uncropped avatar:
    postbit-l.png

    Is this a bug?

    In an enlarged postbit, we need to serve a larger avatar. But the image returned by the system is uncropped and thus totally unusable!
     
  14. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    @psTubble27

    Try using img="false" in the xen:avatar tag.
     
    psTubble27 likes this.
  15. psTubble27

    psTubble27 Well-Known Member

    @Jake Bunce

    Ok I tried it out in various configurations. It doesn't seem to actually be a fix, to be honest. Instead of an image, the system serves a <span> with the entire avatar image in the background. The problem is, it still doesn't serve you the cropped avatar. You're still trying to fit in the uncropped avatar into the userbit.
     
    Last edited: Aug 7, 2014
  16. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It works in my testing. I get a square span with a cropped rectangular avatar in the background.

    Please post a URL showing the problem.
     
  17. psTubble27

    psTubble27 Well-Known Member

    Just to clarify, when "img" is off, the <span> returned by the system in your tests contains a cropped avatar?
     
  18. LuvMeSumZen

    LuvMeSumZen Active Member

    I tried the large av fix linked above (cannot reply there insuf priv's) and it works fine in threads etc. But here's what happened in my PMs . . .
    large avs.jpg

    Do I need to edit something else in style properties/container ? It is probably being caused by my custom theme which I am having removed soon and going back to stock XF. In the meantime I hope there's an edit I can use.
     

Share This Page