• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Service issue WhatsApp dead link

Affected version
v2 release candidate

Chris D

XenForo developer
Staff member
#3
It simply means you don’t have anything installed which can pick up a whatsapp link. It’s WhatsApp so it needs access to a WhatsApp client to work.
 

Martok

Well-known member
#6
You must first download en install WhatsApp for your PC or Mac ;)
Actually you don't need to install anything to get this to work on your PC or Mac, you can use the web version (as I do, I don't have a Whatsapp client installed).

But it is on this forum here.
I've just tested this and, whilst it does work in Chrome, it doesn't work in Firefox or Safari (which is strange, I'm positive I tested this at the time I first mentioned the current solution to Chris).

@Chris D the original solution that I mentioned and you went for is from here: https://faq.whatsapp.com/en/android/26000030/?category=5245251 and the example at the bottom that I guess you based it on is

Code:
https://api.whatsapp.com/send?text=I'm%20inquiring%20about%20the%20apartment%20listing
Having a look around the web for the issue with Firefox and Safari, I came across this:

The solution here is to replace the api part with web
https://webapps.stackexchange.com/q...th-phone-number-doesnt-open-whatsapps-web-app

I've done a test on Chrome, Safari and Firefox on a Mac using the Whatsapp URL from this thread and replacing the api part with web, as suggested. In all cases it seems to work with the added advantage that there's no intermediate window as before, it goes straight to Whatsapp web. I've not tested this on a PC.
 

Robru

Well-known member
#7
Actually you don't need to install anything to get this to work on your PC or Mac, you can use the web version (as I do, I don't have a Whatsapp client installed
If so, more explanation will be required.
If I remove the Whatsapp client from my Mac, I get the same error message as Mr. Lucky.
 

Martok

Well-known member
#9
If so, more explanation will be required.
If I remove the Whatsapp client from my Mac, I get the same error message as Mr. Lucky.
As I said, if you use Chrome (including on a Mac - it works for me) then it works without any Whatsapp application installed.

With the change I suggested via stackoverflow (changing the URL from api to web) then it should work on all browsers.
 

Robru

Well-known member
#10
As I said, if you use Chrome (including on a Mac - it works for me) then it works without any Whatsapp application installed.
Why would Xenforo implement something new that does not work with the best-known browsers. This should be a browser independent...

With the change I suggested via stackoverflow (changing the URL from api to web) then it should work on all browsers.
Is there a work around for that?
 

Mr Lucky

Well-known member
#11
Firefox is a bit better than Safari as it seems to give you an explanation as opposed to what just appears a dead link or error

FirefoxScreenshot008.png

And Google as mentioned works just fine

Google ChromeScreenshot006.png

There needs to be a way to make this more user-friendly on all browsers
 

Chris D

XenForo developer
Staff member
#12
Why would Xenforo implement something new that does not work with the best-known browsers. This should be a browser independent...
With it in its current form, using the current whatsapp:// URL, there's not really a lot we can do to change how a browser decides to handle that.

The behaviour really is no different to the email link which also will similarly not work if the computer or browser being use does not have access to a mail account. In some cases this link will do nothing, in other cases it will launch a default mail client which might not even be what you use if you use, say, Webmail, and in other cases it will give you an error. It's all down to how the browser decides to handle the link.

That all said, we will try and implement the suggestion that @Martok has made as long as it doesn't pose other undesirable issues for other users as the original version did before it was changed back to the whatsapp:// link.
 

Martok

Well-known member
#13
That all said, we will try and implement the suggestion that @Martok has made as long as it doesn't pose other undesirable issues for other users as the original version did before it was changed back to the whatsapp:// link.
I've just done some further testing with the stackoverflow change. Whilst it does work with the 3 major browsers (as far as I can see) on a desktop machine (I'm testing on a Mac), it doesn't work when using a mobile browser (well at least not Chrome on Android) which it seems to just direct you to the main Whatsapp website. Another downside for desktop users is that the stackoverflow change would mean it would always use the web version, even if you have the desktop client installed, which is probably undesirable.

I'm sure I tested the current solution on all browsers prior to it being implemented, so I'm not sure why it doesn't work with Safari or Firefox but does work with Chrome. It may be that the current solution is the best for those on mobile devices, on desktops with Whatsapp app installed and desktops with Chrome and no desktop app installed, but it won't work for desktop users with no app installed and who use Firefox or Safari.
 

Chris D

XenForo developer
Staff member
#14
I rolled a change out here briefly just so I could test it properly and all devices properly. Changing the api link to web is not going to work. It literally forces everything to WhatsApp web, even if you have a WhatsApp client installed. That's nowhere near what I'd expect the behaviour to be, if I'm a WhatsApp user. If I'm not a WhatsApp user, why would I be clicking it in the first place?

I have noted, however, that this is all down to an apparent change of behaviour in how WhatsApp handles the link. It seems as though they launch a window which then automatically tries to launch a WhatsApp app link, whether you have an app installed or not.

Ironically, this works better in Chrome on macOS than it does in Safari on macOS. Chrome at least prompts you to open the app store. Safari just gives up.

All thing's considered, there's no obvious reason to need to change this right now. If you don't have WhatsApp (or don't know what it is) you're unlikely to click it anyway. Any behaviour that doesn't appear to be "correct" is just a quirk of the browser that doesn't know how to handle it, or WhatsApp's own assumption that everyone has the client installed.

Ultimately, if this is a problem for your community, switch if off under Admin > Setup > Options > Sharing options.