1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 What should be the right chmod for /public_html/internal_data/templates/* files?

Discussion in 'Installation, Upgrade, and Import Support' started by RoldanLT, Sep 24, 2013.

  1. RoldanLT

    RoldanLT Well-Known Member

    I have an error while upgrading to xf 1.2.2, permission error.
    I upgrade thru ssh/cli command.

    But when I check my files inside /public_html/internal_data/templates/* all files are chmod 200, so I change to 666, and solve my problem.
     
  2. RoldanLT

    RoldanLT Well-Known Member

    and also /public_html/internal_data/temp/* files are chmod 600, is this fine?

    I think xfhost.net server of @Mike Edge is using Fast CGI
     
  3. Mike

    Mike XenForo Developer Staff Member

    It's very dependent on server settings. Either 0666/0777 if your PHP runs as "nobody" (the web server user) or 0644/0755 if it runs as "your" user (suPHP for example).

    I suppose doing some things via the CLI could trigger some problems as the context is very different from normal (so our normal chmod decision detection ends up giving different results). However, if you run the command as the same user that PHP normally runs as, that should solve that issue.
     
    RoldanLT likes this.
  4. RoldanLT

    RoldanLT Well-Known Member

    I can confirm, doing the upgrade thru ssh/cli change all the permissions of this files: /public_html/internal_data/templates/*
     

Share This Page