• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 What are the correct Sendgrid settings?

#1
I have a sendgrid account that I use with Clickfunnels and it works perfectly. I tried hooking it up to xenforo under "email options" but it kept throwing authentication errors. I switched the emails back to just the default and the errors are gone. BUT at scale I don't want to relay on the default emails going out from my server. I want to hook it up to sendgrid.

Is this possible and is there anything in the manual about this? (The correct settings).
 

Mike

XenForo developer
Staff member
#2
The settings would really normally need to come from Sendgrid (the SMTP provider). What sort of errors were you getting?
 
#3
This is in the server error log...it's weird though because some emails do go out and it seems some random ones do not.


Server Error Log
Error Info Zend_Mail_Protocol_Exception: Email to **********@hotmail.com failed: Incorrect authentication data - library/Zend/Mail/Protocol/Abstract.php:431
Generated By: Unknown Account, Today at 1:27 PM
Stack Trace #0 /home/ppccoach/public_html/forums/library/Zend/Mail/Protocol/Smtp/Auth/Login.php(95): Zend_Mail_Protocol_Abstract->_expect(235)
#1 /home/ppccoach/public_html/forums/library/Zend/Mail/Protocol/Smtp.php(217): Zend_Mail_Protocol_Smtp_Auth_Login->auth()
#2 /home/ppccoach/public_html/forums/library/Zend/Mail/Transport/Smtp.php(217): Zend_Mail_Protocol_Smtp->helo('localhost')
#3 /home/ppccoach/public_html/forums/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#4 /home/ppccoach/public_html/forums/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#5 /home/ppccoach/public_html/forums/library/XenForo/Mail.php(175): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
#6 /home/ppccoach/public_html/forums/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#7 /home/ppccoach/public_html/forums/library/XenForo/Model/UserConfirmation.php(165): XenForo_Mail->send('kmcorbett@hotma...', 'Karen')
#8 /home/ppccoach/public_html/forums/library/XenForo/ControllerPublic/Register.php(424): XenForo_Model_UserConfirmation->sendEmailConfirmation(Array)
#9 /home/ppccoach/public_html/forums/library/XenForo/FrontController.php(351): XenForo_ControllerPublic_Register->actionRegister()
#10 /home/ppccoach/public_html/forums/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#11 /home/ppccoach/public_html/forums/index.php(13): XenForo_FrontController->run()
#12 {main}
Request State array(3) {
["url"] => string(55) "http://ppc-coach.com/forums/index.php?register/register"
["_GET"] => array(1) {
["register/register"] => string(0) ""
}
["_POST"] => array(14) {
["username"] => string(0) ""
["a4338eaced81b488cd3d44f0d906ac33"] => string(5) "Karen"
["d869e079c98644ebbd8a08fe596327e4"] => string(21) "***********@hotmail.com"
["password"] => string(8) "********"
["f6028f56f377b61e5a4e90a20c129ea5"] => string(6) "female"
["dob_month"] => string(1) "3"
["dob_day"] => string(1) "3"
["dob_year"] => string(4) "1977"
["6ec8289ffbb2c78d948b7a630fe8d686"] => string(13) "Europe/London"
["recaptcha_challenge_field"] => string(228) "03AO6mBfweqj9fgb8zYhRhZO7SDg98VhnMtxxHwe3r25hLszxIpHJ0Bs0ztqobt7wvubQxn2StZ1DrAZNgfq0-agqQoqy5AWaFuS2msMgKFYXcMkch_0kq8fek0vuzUXlHumRBTrjbCzAYHmxIMKwgsEXe2o1vPFWQwR6IBTqrnm7rNwj8NnPhUlhpLDXh8b2EHNdm1zsUi-o_CI2ItRgMAnhUEko1ch8diw"
["recaptcha_response_field"] => string(17) "IMPERIA FAIRMOUNT"
["agree"] => string(1) "1"
["_xfToken"] => string(8) "********"
["reg_key"] => string(32) "842108406088e78bbdac8c50c432cb2c"
}
}
 

Mike

XenForo developer
Staff member
#6
If you are getting inconsistent data, that would seem to imply some sort of issue with Sendgrid itself -- we'd be sending the same username/password for each request.