1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Weird problem with permissions not changing on Private forums

Discussion in 'XenForo Questions and Support' started by leslie dow, Sep 15, 2016.

  1. leslie dow

    leslie dow Active Member

    I have a number of forums that I have made Private and I add users to them manually. Sometimes I need to change them back so access is controlled via a usergroup. When I do that I find that the permissions are sticky, for lack of a better word. According to Analyze Permissions, a user should have access but when I try to access the forum as that user I cannot. I've tried this with a number of forums and this happens only when I am switching a forum from Private to Usergroup controlled. Any ideas what is going on?

  2. Mike

    Mike XenForo Developer Staff Member

    When you have the problem, go to rebuild caches and rebuild the user cache. Does that resolve the problem? If so, that would indicate that there's a bad add-on involved which is preventing permissions from being updated as needed. Unfortunately, it's not trivial to identify, so make sure you're using the latest version of all add-ons.
  3. leslie dow

    leslie dow Active Member

    Nope, I tried all of that. I have rebuilt all the caches. Good idea about the addons, I will disable some on my test site and see if that fixes anything.

  4. leslie dow

    leslie dow Active Member

    Ok, that didnt work. I've disabled all the addons and rebuilt the user cache. Still nothing. I have double checked and my ACP- Analyze permissions says that this user should have access but I don't. Any idea what this could be if it's not related to Addons?

  5. Brogan

    Brogan XenForo Moderator Staff Member

    What do you mean by "but I don't"?

    Are you using the test permissions function?

    The permissions analyzer results are likely correct.
  6. leslie dow

    leslie dow Active Member

    I am the user that I am trying to give access to. I've tried others, as well so it's not just my account. And yes, I was using the test permissions--Analyze permissions its called in my ACP and that says I (the account) should have posting permissions, but when I go to those forums, there is a notice that says: (You have insufficient privileges to post here.)

    According to Analyze Permissions, that account should be able to post.
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Try disabling all add-ons and then unsetting and resetting the permission (although that should do the same as rebuilding the cache so may not make any difference).

    Every time we have seen issues of this nature it has been due to a third party add-on.

    You're not using something like amember are you?

    Failing that you may need to look at getting someone to investigate the issue in more depth.
  8. leslie dow

    leslie dow Active Member

    I did disable all add-ons, and then systematically added them back, in batches. I still see the problem in my test site with no add-ons enabled. All the add-ons I use are updated to the most current version; any add-ons that are unsupported I have stopped using.

    Also, I only see this intermittently. When I first posted this, it was happening on both my main site and my test site. Now, my main site is fine but I still see the problem on my test site. The only real difference between my main and test site, is that my test site is a copy of my main site with all but staff and test users removed. Could that be causing issues? I removed them via batch update in the ACP.

  9. Mike

    Mike XenForo Developer Staff Member

    It's not clear why this is happening, but if it's happening right now on the test site, can you submit a ticket from your customer area with ACP access and some specific details of the problem (example user it applies to, the forum in question, etc)? We can look into it then.

Share This Page