• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Weird glitch with Style Property used in conditional statement?

whitesky

Active member
#1
Searched through the forum and didn't see this specifically asked before.
I've tested the following from Conditionals page to show content to the default four usergroups:
Code:
<xen:if is="{xen:helper ismemberof, $visitor, 1,2,3,4">
   content here...
</xen:if>
This works fine when testing in each group. However I tried creating a scalar string property (ie. @showtoUsergroups), which is defaulted to 1,2,3,4.

I then modified the code to be:
Code:
<xen:if is="{xen:helper ismemberof, $visitor, @showtoUsergroups">
   content here...
</xen:if>
This code worked if only two numbers were specified. If I enter three or more integers in the property, it won't work. Sometimes playing with the order of the numbers produces different results. Sometimes it wouldn't produce anything.

Am I missing something or is this invalid? I even displayed the property within a span just to see if the output was writing "1,2,3,4".

Thanks for any input.