XF 2.1 Weird cookie notice - Not showing up for everyone.

Sportsoutlaw

Active member
I have member getting a notice saying that "this site uses cookies to better your browsing experience" It has a link to our privacy policy, and the option to accept or decline.

Problem is, you accept, and it still continues to pop up.

I had no idea what the members were talking about until today, I logged out of my phone hotspot, and logged my laptop into a mcdonalds wifi. As soon as I did, I was getting the notice. It pops up on the bottom right hand corner of the page. I clicked "accept", but it continued to come back. Logged out of that wifi, and back to the hotspot from my phone, and it went away.

Any idea why this happens?
 

Sportsoutlaw

Active member
I noticed that Cloudflare's Rocket Loader causes this problem, if you use that, try disabling it.
Well, this didn't solve the problem.

However, I think this problem showed up close to the time that I upgraded cloudflare to get their more premium features. Going to try shutting all of that down and see what happens.
 

Chris D

XenForo developer
Staff member
As Matt mentions above, but just to be clear: That cookie notice isn't coming from XenForo.
 

Blue chummer

Active member
I also get this new error message when logging in to my site(which I am redeveloping)

"Oops! We ran into some problems.
Cookies are required to use this site. You must accept them to continue using the site."

using chrome
 

Chris D

XenForo developer
Staff member
I also get this new error message when logging in to my site(which I am redeveloping)

"Oops! We ran into some problems.
Cookies are required to use this site. You must accept them to continue using the site."

using chrome
That's unrelated so would likely need a separate thread to discuss it.

In recent times though, that has cropped up if there are server config issues. Particularly if you have your site available on both http and https URLs, sometimes cookies can be blocked on either one.

You may want to simply consider contacting your host in the first instance as, ultimately, either your server isn't setting or reading the cookies.
 

Sportsoutlaw

Active member
I have disabled everything I can think of with Cloudflare other than simply using their nameservers, no idea what could be causing this.
 

ozzy47

Well-known member
Disable CloudFlare completely, then the notice should go away, it is not an XenForo notice.
 

Sportsoutlaw

Active member
Disable CloudFlare completely, then the notice should go away, it is not an XenForo notice.
I have disabled everything other than just using their nameservers. I was hoping to avoid making that switch because I don't want to risk extended downtime.
 
Top