1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Weekly Statistics

Discussion in 'Resolved Bug Reports' started by MattW, Jul 16, 2013.

  1. MattW

    MattW Well-Known Member

    weekly_stats.PNG

    The drop in the middle is Week 53......I thought there were only 52 weeks in a year?
     
    Shelley likes this.
  2. Shelley

    Shelley Well-Known Member

    :LOL: Classic. :ROFLMAO:
     
    MattW likes this.
  3. RobParker

    RobParker Well-Known Member

    Leap year issue maybe?
     
  4. Mike

    Mike XenForo Developer Staff Member

  5. Brogan

    Brogan XenForo Moderator Staff Member

    There's also a week 53 on my site.
     
  6. rellek

    rellek Well-Known Member

    Me too. On both natively grown and generated by "Rebuild Caches".
     
  7. MattW

    MattW Well-Known Member

    I'm also seeing it on an old localhost test install I did at work

    week53.PNG
     
  8. MattW

    MattW Well-Known Member

    @Brogan & @Mike

    UTC or BST?

    All my servers are running BST

    Code:
    z22se@z22se.co.uk [~/scripts]# date
    Tue Jul 16 09:58:31 BST 2013
    
    matt@Matt-PC:/etc$ date
    Tue Jul 16 09:58:19 BST 2013
    
    [mworthington@air-inocapps1 ~]$ date
    Tue Jul 16 09:58:41 BST 2013
    Wonder if that might be the issue?
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    BST also: Tue Jul 16 10:03:52 BST 2013
     
  10. rellek

    rellek Well-Known Member

    I have CEST.

    root@cyberdyne2:~$ date
    Tue Jul 16 11:04:53 CEST 2013
    root@cyberdyne2:~$
     
  11. rellek

    rellek Well-Known Member

    Is this maybe a problem with time zones? I just hit

    root@cyberdyne2:~$ date +%W
    28
    root@cyberdyne2:~$

    where my OS X Calendar says, we're in week 29. Which is kinda funny, because the same command under OS X returns 28 as well.

    Edit:
    and Dec 31 2012 was week 53, according to my linux server.

    root@cyberdyne2:~$ date -d20121231 +%W
    53
    root@cyberdyne2:~$
     
  12. Mike

    Mike XenForo Developer Staff Member

    This is fixed now. I'm actually not sure why it didn't happen here with that code. :)
     
    shenmuee and MattW like this.

Share This Page