XF 2.0 Website down (Unknown mysql server host)

When I go to my xenforo 2 website I get just a white screen. Its hosted on godaddy and this is what they found.

[22-Jan-2022 07:42:47 UTC] PHP Fatal error: Uncaught XF\Db\Exception: Unknown MySQL server host 'sonicvisions.db.10993323.af2.hostedresource.net' (0) in /home/g6d0jdzkbrhq/public_html/sonicvisions.org/forum/src/XF/Db/Mysqli/Adapter.php:160

The godaddy agent said:

The MySQL should be localhost as this is a cPanel hosting.

So is this something godaddy has to fix or something I can? thanks.
 

DreamNetworks

Active member
Hi,

This is something you can fix yourself :)

Go to your FTP and go to src/config.php open it in notepad or something and you will find the issue :) Change, save and re-upload and everything should be fine
 
Ok did the change and now I am getting this error when going to the website:

"Fatal error: Uncaught XF\Db\Exception: Access denied for user 'sonicvisions'@'localhost' (using password: YES) in /home/g6d0jdzkbrhq/public_html/sonicvisions.org/forum/src/XF/Db/Mysqli/Adapter.php:160 Stack trace: #0 /home/g6d0jdzkbrhq/public_html/sonicvisions.org/forum/src/XF/Db/Mysqli/Adapter.php(28): XF\Db\Mysqli\Adapter->makeConnection(Array) #1 /home/g6d0jdzkbrhq/public_html/sonicvisions.org/forum/src/XF/Db/AbstractAdapter.php(60): XF\Db\Mysqli\Adapter->getConnection() #2 /home/g6d0jdzkbrhq/public_html/sonicvisions.org/forum/src/XF/Db/Mysqli/Adapter.php(113): XF\Db\AbstractAdapter->connect() #3 /home/g6d0jdzkbrhq/public_html/sonicvisions.org/forum/src/XF/Db/AbstractAdapter.php(516): XF\Db\Mysqli\Adapter->escapeString('options') #4 /home/g6d0jdzkbrhq/public_html/sonicvisions.org/forum/src/XF/Db/AbstractAdapter.php(494): XF\Db\AbstractAdapter->quote('options') #5 /home/g6d0jdzkbrhq/public_html/sonicvisions.org/forum/src/XF/DataRegistry.php(138): XF\Db\AbstractAdapter->quote(Array) #6 /home/g6d0jdzkbrhq/public_html/soni in /home/g6d0jdzkbrhq/public_html/sonicvisions.org/forum/src/XF/Db/Mysqli/Adapter.php on line 160"
 

Brogan

XenForo moderator
Staff member
As an aside, if the site was previously working then something was changed for the mysql details, the config file, or both.

I would recommend investigating further to discover who made the change and why.
 

DreamNetworks

Active member
As an aside, if the site was previously working then something was changed for the mysql details, the config file, or both.

I would recommend investigating further to discover who made the change and why.
I was thinking exactly the same, but didn't asked it yet. Because if it's as we think it could also maybe a cnfig.php injection ?
 
I never changed it though. And I am looking at its accurate to what I originally set, My host says they can't do anything and its a content issue.

What can I do now? Is my whole install screwed now?
 
In my database control panel it only lists 2 users. The credentials of those users don't match my login. So I tried to create a new user that matches the credentials but then it says 'that user already exists'.
 

DreamNetworks

Active member
In my database control panel it only lists 2 users. The credentials of those users don't match my login. So I tried to create a new user that matches the credentials but then it says 'that user already exists'.
If that user already exists and you don't actually see the user between the users. Contact your hosting exactly whit this issue.
 
Top