1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Watched Forum Error

Discussion in 'XenForo Questions and Support' started by Surf3rDud3, Sep 9, 2013.

  1. Surf3rDud3

    Surf3rDud3 Member

    I get this error when clicking Watched Forums... I know this error has something to do with the [bd] Forum Watch

    Code:
    An exception occurred: Invalid argument supplied for foreach() in /usr/www/surf3rdud3/public/beerspub.com/library/XenForo/ViewPublic/Watched/Forums.php on line 21
    
    XenForo_Application::handlePhpError() in XenForo/ViewPublic/Watched/Forums.php at line 21
    XenForo_ViewPublic_Watched_Forums->renderHtml() in XenForo/ViewRenderer/Abstract.php at line 227
    XenForo_ViewRenderer_Abstract->renderViewObject() in XenForo/ViewRenderer/HtmlPublic.php at line 67
    XenForo_ViewRenderer_HtmlPublic->renderView() in XenForo/FrontController.php at line 572
    XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
    XenForo_FrontController->run() in /usr/www/surf3rdud3/public/beerspub.com/index.php at line 13
     
  2. CyclingTribe

    CyclingTribe Well-Known Member

    You should be safe uninstall [bd] Forum Watch - you don't need it with XF 1.2 as forum watching is now built into the core. (y)
     
  3. Surf3rDud3

    Surf3rDud3 Member

    I do not have it installed. I uninstalled it when I upgraded to 1.2 about 2 or 3 months ago.
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    Did you run the queries as instructed?
     
  5. Surf3rDud3

    Surf3rDud3 Member

    I have before. but if you can link me or get them to me again I'll give it another go.
     
  6. Jeremy

    Jeremy XenForo Moderator Staff Member

  7. Surf3rDud3

    Surf3rDud3 Member

    Ok I have done this and it is still occuring.

    First Error...

    Code:
    Error Info
    ErrorException: Undefined index: nodeParents - library/XenForo/ViewPublic/Watched/Forums.php:13
    Generated By: Surf3rDud3, A moment ago
    Stack Trace
    #0 /usr/www/surf3rdud3/public/beerspub.com/library/XenForo/ViewPublic/Watched/Forums.php(13): XenForo_Application::handlePhpError(8, 'Undefined index...', '/usr/www/surf3r...', 13, Array)
    #1 /usr/www/surf3rdud3/public/beerspub.com/library/XenForo/ViewRenderer/Abstract.php(227): XenForo_ViewPublic_Watched_Forums->renderHtml()
    #2 /usr/www/surf3rdud3/public/beerspub.com/library/XenForo/ViewRenderer/HtmlPublic.php(67): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Html', Array, 'watch_forums')
    #3 /usr/www/surf3rdud3/public/beerspub.com/library/XenForo/FrontController.php(572): XenForo_ViewRenderer_HtmlPublic->renderView('XenForo_ViewPub...', Array, 'watch_forums', NULL)
    #4 /usr/www/surf3rdud3/public/beerspub.com/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_HtmlPublic), Array)
    #5 /usr/www/surf3rdud3/public/beerspub.com/index.php(13): XenForo_FrontController->run()
    #6 {main}
    Request State
    array(3) {
      ["url"] => string(34) "http://beerspub.com/watched/forums"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(0) {
      }
    }
    Second Error...

    Code:
    Error Info
    ErrorException: Invalid argument supplied for foreach() - library/XenForo/ViewPublic/Watched/Forums.php:21
    Generated By: Surf3rDud3, 1 minute ago
    Stack Trace
    #0 /usr/www/surf3rdud3/public/beerspub.com/library/XenForo/ViewPublic/Watched/Forums.php(21): XenForo_Application::handlePhpError(2, 'Invalid argumen...', '/usr/www/surf3r...', 21, Array)
    #1 /usr/www/surf3rdud3/public/beerspub.com/library/XenForo/ViewRenderer/Abstract.php(227): XenForo_ViewPublic_Watched_Forums->renderHtml()
    #2 /usr/www/surf3rdud3/public/beerspub.com/library/XenForo/ViewRenderer/HtmlPublic.php(67): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Html', Array, 'watch_forums')
    #3 /usr/www/surf3rdud3/public/beerspub.com/library/XenForo/FrontController.php(572): XenForo_ViewRenderer_HtmlPublic->renderView('XenForo_ViewPub...', Array, 'watch_forums', NULL)
    #4 /usr/www/surf3rdud3/public/beerspub.com/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_HtmlPublic), Array)
    #5 /usr/www/surf3rdud3/public/beerspub.com/index.php(13): XenForo_FrontController->run()
    #6 {main}
    Request State
    array(3) {
      ["url"] => string(34) "http://beerspub.com/watched/forums"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(0) {
      }
    }
     
  8. Jeremy

    Jeremy XenForo Moderator Staff Member

    Can you run a file health check?
     
  9. Mike

    Mike XenForo Developer Staff Member

    There must be another add-on that conflicts. I'd disable add-ons one by one until you resolve it. (Alternatively, look for updates for your other add-ons.)
     
    Amaury likes this.
  10. Surf3rDud3

    Surf3rDud3 Member

    CyclingTribe likes this.

Share This Page