• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Watched Forum Error

OverHere

Active member
#1
At http://satisfy.tv/watched/forums I am getting this error:

An exception occurred: Invalid argument supplied for foreach() in /var/www/vhosts/satisfy.tv/httpdocs/library/XenForo/ViewPublic/Watched/Forums.php on line 21
  1. XenForo_Application::handlePhpError() in XenForo/ViewPublic/Watched/Forums.php at line 21
  2. XenForo_ViewPublic_Watched_Forums->renderHtml() in XenForo/ViewRenderer/Abstract.php at line 227
  3. XenForo_ViewRenderer_Abstract->renderViewObject() in XenForo/ViewRenderer/HtmlPublic.php at line 67
  4. XenForo_ViewRenderer_HtmlPublic->renderView() in XenForo/FrontController.php at line 572
  5. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  6. XenForo_FrontController->run() in /var/www/vhosts/satisfy.tv/httpdocs/index.php at line 13
What is causing this error? And, what does my developer need to do to fix this?

Thanks.
 

Chris D

XenForo developer
Staff member
#2
You should first of all disable all add-ons to see if the error goes away.

Usually this error means that an array is no longer an array. Maybe something has been overwriting it with a string or some function is returning false instead of array().

So, disable all add-ons first. When you have, does the error go away?
 

OverHere

Active member
#4
So. Did you fix this? What was the issue?
Thank you - this seems to be solved for now and the issue is a custom mod I had made for my website. I'm not too confident though as the custom mod keeps causing errors periodically and the coder cannot seem to fix the issue indefinitely.
I may need to ask another coder to re-do this custom mod for me.