1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 WARNING: [pool www] server reached pm.max_children setting (5), consider raising it

Discussion in 'Troubleshooting and Problems' started by Nentify, Feb 8, 2014.

  1. Nentify

    Nentify Member


    I'm getting the error below, and can't seem to fix it

    [07-Feb-2014 16:30:36] WARNING: [pool www] server reached pm.max_children setting (5), consider raising it

    This occurs when I use the rule:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^tekkify.com$ [NC]
    RewriteRule ^(.*)$ http://forums.tekkify.com/$1 [R=301,L]

    or something similar in my .htaccess on my old VPS site to redirect to my new site at forums.tekkify.com. However, when I add the re-direct and try to access the site, php5-fpm craps out and gives me the error above. I've tried increasing the pm.max_children value, but got a similar error with the first five getting:

    [07-Feb-2014 19:02:40] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 32 children, there are 0 idle, and 8 total children

    If you need anymore information, let me know. Would really like to get this fixed.

    To make it clear:
    • The new site (forums.tekkify.com) works 100% fine without the apache redirect from the old site (tekkify.com)
    • The new site stops working completely, doesn't even load 1 page when the redirect is active from the old site.
    • The new site runs on nginx
    • The old site runs on apache, if these two pieces of information have any impact. Didn't think they would though.
    Last edited: Feb 8, 2014
  2. Slavik

    Slavik XenForo Moderator Staff Member

    Whats your pm.max_requests set to?
  3. Nentify

    Nentify Member

    5, also tried 10, 15 and 50.
  4. Slavik

    Slavik XenForo Moderator Staff Member

    Try setting it to 0
  5. Nentify

    Nentify Member

    root@tekkify:/etc/nginx# service php5-fpm restart
    * Restarting PHP5 FastCGI Process Manager php5-fpm [fail]

    When set to 0.

    Edit: Oh, sorry. Wrong value. My max_requests was unset (had ; before it).
  6. Slavik

    Slavik XenForo Moderator Staff Member

    0 should be the default setting for that IIRC.

    I would suggest you have some misconfiguration somewhere.
  7. Nentify

    Nentify Member

    I was reading the wrong value, it was unset (; before it). I thought you said max_children.

Share This Page