1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Visitors get "Internal Server Error" for page nodes

Discussion in 'Troubleshooting and Problems' started by MikeMpls, Dec 27, 2012.

  1. MikeMpls

    MikeMpls Well-Known Member

    In one of my XF boards, unregistered users can no longer view page nodes. They get this message instead:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, cgiadmin@yourhostingaccount.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.​

    There is code in the templates to show ads to unregistered users, and javascript to relocate the main ad block to the top of the screen when they first link into the middle of a thread, but none of this involves URL redirects. The code is also identical to code functioning correctly on other XF sites.

    The easiest way to reproduce it is to try to access the privacy policy:


    Any suggestions? I'm stumped, but only discovered this an hour ago ...
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It only happens for guests? Not members?

    A 500 ISE error is very generic. It is an error returned by your server. To discover the exact cause requires consulting with your host to pull the error logs on the server. Many times this error is caused by an overly restrictive mod_security rule, or some other server module. Contact your host.
     
    vVv and Chris D like this.
  3. vVv

    vVv Guest

    Jake Bunce likes this.
  4. MikeMpls

    MikeMpls Well-Known Member

    Is mod rewrite support mandatory for XF?

    They tried to disable that for me a few years ago when i was running vBulletin + vbSEO. Only a barfing smilie can describe how well that worked.

    Unfortunately my fully-functioning XF sites are in other accounts.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    For friendly URLs, yes. Otherwise no.

    mod_rewrite shouldn't have anything to do with this error.
     
  6. melbo

    melbo Well-Known Member

    I can see your privacy policy just fine as a guest
     
    Jake Bunce likes this.
  7. MikeMpls

    MikeMpls Well-Known Member

    I added a simple "mike-test" page node to the simpler forums that had no page nodes, and managed to reproduce the problem in one other XF board.

    Problem is, there are 4 XF boards in that account, and page nodes were working in the 3 of them. That kind of eliminates server configuration, so I started looking for other commonalities.

    It works when I disable the XenTags add-on for the two sites.

    Wrap-up so far:
    • Two sites using XenTags 1.3.3, page nodes don't work for guests
    • Three sites using XenTags 1.2.12, one using XenTags 1.2.6, page nodes seem to work ok for everyone
    Will report back w/ a final resolution or at least a link to a post in the XenTags thread when I'm done.

    Thanks for the suggestions (and I'd still like to know if mod rewrite is mandatory or optional for XF).
     
  8. MikeMpls

    MikeMpls Well-Known Member

    Yes, by the time you tried it I had disabled the XenTags add-on (see my previous post).
     
    vVv likes this.
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That may be, but this is not an error returned by XenForo or an addon. It's a server error. An addon may be triggering the error somehow, but it's still a server error. You should consult with your host to pull the error log and find the exact cause. Simply identifying a trigger may not permanently fix the problem.
     
  10. melbo

    melbo Well-Known Member

    500 errors can be tricky to track down. I still have a few when accessing (as guest) some blogs that were converted to threads (vb 3 to XF). I can't figure them out and have pretty much given up.
     
  11. MikeMpls

    MikeMpls Well-Known Member

    Nothing permanently resolved tonight, any continuing discussion will likely be in the XenTags thread commencing here.
     

Share This Page