• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Very strange problem

Chad

Active member
#1
Hey I hope someone can figure this out. This one is baffling me.

So I've tried a few mobile testing sites like the below.

For whatever reason, talkjesus.com is not showing up (even with www prefix). I've tried a handful of other responsive based domains I own, they all work fine except talkjesus.com But, the site surely loads on mobile phones anyway. The weird thing though, why are NONE of these browser testing sites showing it?

http://mattkersley.com/responsive/
http://responsivetest.net/#u=http://www.talkjesus.com|640|1136|2
http://quirktools.com/screenfly/#u=http://www.talkjesus.com/&w=375&h=667&a=37&p=1

Anyone have an idea? This is my htaccess (again, it technically loads on mobile browsers, or at least does for me in Safari / iPhone 6.

Code:
RewriteEngine On
RewriteRule ^[^/]+/([0-9]+)-[^\.]+\.html$ /index.php?threads/$1/ [R=301,L]
RewriteCond %{HTTP_HOST} !^www\.talkjesus\.com$
RewriteRule ^(.*)$ http://www.talkjesus.com/forum/$1 [R=301,L]
   
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default

<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /

    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 

Chad

Active member
#4
Sorry need clarification on something.

Should the line look like this

$config['enableClickjackingProtection'] - default: false

or this

$config['enableClickjackingProtection'] - true
 

Brogan

XenForo moderator
Staff member
#5
The default is true so if you want to disable the protection, set it to false.
Code:
$config['enableClickjackingProtection'] = false;