1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 vbseo to xenforo url

Discussion in 'Installation, Upgrade, and Import Support' started by eagle eyes, Feb 12, 2016.

  1. eagle eyes

    eagle eyes Active Member

    http://www.domain.com/forums/section-name/264655-thread-60-name.html

    to xenforo url like this

    http://domain.com/threads/8-thread-name.421672/

    Below is my .htaccess (how can i fix it)

    my current .htaccsss doesn't work.


    Code:
    ErrorDocument 401 default
    
    
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule ^forums/[^/]+/([0-9]+)-.+-([0-9]+)\.html$ /threads/$1/page-$2 [R=301,L]
    RewriteRule ^forums/[^/]+/([0-9]+)-.+\.html$ /threads/$1/ [R=301,L]
    
    RewriteCond %{HTTP_HOST} !^domain\.com$
    RewriteRule ^(.*)$ http://domain.com/$1 [R=301,L]
    
    # If you are having problems with the rewrite rules, remove the "#" from the
    # line that begins "RewriteBase" below. You will also have to change the path
    # of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
    
    # This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is your web root .htaccess? It looks fine to me. It should work.

    If the problem persists then I can take a look if you give me access.
     
    eagle eyes and The Forum Heroes like this.
  3. The Forum Heroes

    The Forum Heroes Well-Known Member

    Yes, it's the webroot, using Litespeed
     
  4. The Forum Heroes

    The Forum Heroes Well-Known Member

    Playing around with it, using RewriteRule ^/forums instead of RewriteRule ^forums fixed it. Odd as it worked using the latter until upgrading to php7 and latest LiteSpeed.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Interesting. Apache never includes the beginning forward slash. That must be a LiteSpeed thing.
     
    The Forum Heroes likes this.

Share This Page